Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't click on my name in XonStats

I have downloaded Xonotic via the Linux Mint software center about a month ago. I've been playing some games, and I wanted to look at them inside of XonStats. I do notice that my ingame name shows up perfectly, some examples including:
(I have the same ingame name as in this forum)
However, I can't click on my name at all. I have set both tracking options inside "Profile", I've even set the cvars cl_allow_uid2name and cl_allow_uidtracking to 1, I also checked my .xonotic folder (the key_0.d0si file referred to in the XonStats FAQ does indeed exist), but it still does not seem to work. When I search for my name, it also doesn't show up at all.
What could the issue be? Is it because of the GDPR, or because I've installed it using the software center rather than downloading it, or is it something different entirely?
I'd appreciate any help!


EDIT: I found out that the .xonotic Folder was last changed a few days prior, when I wanted to introduce a friend to Xonotic and it wouldn't work for him, so I downloaded the zip from and it asked me to create another user. So apparently, it is because of the software center, that version apparently won't change anything inside the .xonotic folder at all. I'll just use the downloaded version from now on! Thank you anyway Smile

When you install Xonotic using the Ubuntu Software Center it is probably installed usingĀ snap.
Therefore it does not use ~/.xonotic as user folder. To figure out which folder is used, you can enter `which config.cfg` into console (SHIFT+ESC).
It will return the location of your configuration file and thus the location of the user folder.

To verify a crypto key has been loaded you can enter `crypto_keys` into console.

Hey, I got the same issue, can't click my name andĀ both "cl_allow_uidtracking" and "cl_allow_uid2name" are set.
Entering "apropos config.cfg" in the console doesn't yield any path, but I found it in ~/.xonotic/data/config.cfg
According to the file modification dates this folder is used by Xonotic, I could also find my configuration in this config.cfg file.

"crypto_keys" gives no results.
Am I just missing this key? "crypto_keygen" says

crypto_keygen id url
but what does it mean by "id" and "url"?

I'm running openSUSE Tumbleweed, Xonotic 0.8.2.

I meant `which config.cfg`. (I corrected it in the earlier post.)
If the command `crypto keys` does not exist, you have installed the game without d0_blind_id, or the game cannot find the library.

You do not have to do these steps manually. The game does it for you if the key does not exist. However, because you are lacking the crypto library it does not work for you.


Does the command `crypto_keygen` exists for you in console? That seems to be weird if `crypto_keys` does not exist...

"libd0_blind_id0" was installed with xonotic here. The command "crypto_keygen" exists as I said, and it prints usage information when I enter it.
I also installed "libd0_rijndael0" and "d0_blind_id" but when I right-click on a server in the list it says "auth library missing".

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Can't hear the announcer voice anymore gianmarco 4 923 01-16-2024, 12:26 PM
Last Post: gianmarco
  [INVALID] Resolution can't be changed Majki 17 13,811 08-14-2022, 02:41 AM
Last Post: FAF
  [NEED HELP] Can't set 2k resolution noteven 4 3,262 05-07-2021, 02:33 PM
Last Post: noteven
  [NEED HELP] Can't join anymore fenjrill 5 3,338 07-17-2020, 07:04 AM
Last Post: LegendGuard
  [NEED HELP] Sudden loss of sound in Xonotic, can not get it to return. SeveredinTwain 5 4,377 03-26-2020, 05:55 AM
Last Post: FAF
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 4,131 01-03-2020, 11:31 AM
Last Post: SpiKe
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 7 5,393 12-25-2019, 03:34 PM
Last Post: illwieckz
  [NEED HELP] How can i swap my account on a different pc? GTFO 1 2,013 11-23-2018, 12:42 AM
Last Post: BuddyFriendGuy
  [NEED HELP] can't join any server in the list psy31 2 3,452 11-02-2018, 10:37 AM
Last Post: psy31
  [SOLVED] Can't connect to a server adem 2 3,265 02-23-2018, 06:49 AM
Last Post: adem

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-