Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] xonotic + intel graphics card doesn't function but Nexuiz does

#1
Exclamation 
Having chatted to Samual about this issue, and having spent a few hours trawling through the code, I was wondering whether anyone else has more information on this subject. I attach output from Nexuiz (which runs and works fine) and output from a git clone and update of xonotic which doesn't run.

When running Xonotic, I see the title screen just fine, but after approx. 3 seconds the screen goes blank (except for a VERY faint 'watermark') and the CPU maxes out.

My system is Linux (Vector)
My Graphics card is 00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

and the rest of the info should be in the attached files...


Attached Files
.txt   nexuiz_output.txt (Size: 13.66 KB / Downloads: 4)
.txt   output.txt (Size: 32.5 KB / Downloads: 5)
Reply

#2
You appear to be using SDL with Nexuiz and GLX with Xonotic.

Experiment with these
./nexuiz-linux-sdl.sh
./nexuiz-linux-glx.sh

./all run sdl
./all run glx

You can also add '-safe' to the command wiki details, which disables the usage of every goody a graphic card offers.
./nexuiz-linux-sdl.sh -safe
./nexuiz-linux-glx.sh -safe

./all run sdl -safe
./all run glx -safe
Reply

#3
I play Nexuiz with a Intel 4500MHD card on Ubuntu 10.04 using a few tweaks (r_fullbright 1 r_sky 0) and get 40+ fps and no other issues but when I tried Xonotic I had issues with textures not showing up due some texture compression (S3TC DDS? idk) that the 4500 couldn't do either because the drivers didn't support it or the card it self not sure which. Never had Nexuiz or Xonotic just not run to some extent though, weird.
<[-z-]> have you seen the documentary "happy"?
<Samual_> no
<Samual_> it sounds horrible
Reply

#4
If it is because of texture compression issues, you can blame the USA for having software patents. Your intel chip is perfectly capable of decoding S3TC.

The option -nos3tc, passed to the engine, should force software decoding at lower res. Or, you can use a build without any DDS files at all:

http://beta.xonotic.org/autobuild/Xonoti...st-low.zip

Username: xonotic, Pass: g-23
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#5
Also, if you live in a country that doesn't execute you for using patented algorithms to access hardware you paid for: you can install the libtxc_dxtn library, which will enable S3TC support in Mesa.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [BUG] The game seems doesn't recognize virtual 7.1 noctiveqc 2 160 02-17-2019, 02:10 AM
Last Post: martin-t
  [BUG] Graphics become really choppy and laggy on Level 18 Daklota 1 431 11-05-2018, 06:33 AM
Last Post: martin-t
  [NEED HELP] XUbuntu playing with drivers and now Xonotic doesn't start Bla1 10 1,273 05-15-2018, 10:00 PM
Last Post: Lyberta
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 3,715 04-19-2018, 02:42 AM
Last Post: cefiar
Photo [NEED HELP] When in game, the guns keep firing, sometimes doesn't fire when pointed at a target. U1Y5Y5 3 982 09-12-2017, 01:28 PM
Last Post: SpiKe
  [NEED HELP] Strange input lag and graphics lag in 0.8.2 mrdoklata 3 2,101 04-21-2017, 11:00 PM
Last Post: -z-
  [SOLVED] Xonotic doesn't work with overwolf Ch4mp 2 1,656 08-12-2016, 02:44 AM
Last Post: Ch4mp
  [SOLVED] How do I make my zoom like back in Nexuiz Beagle 7 2,780 06-26-2015, 09:40 AM
Last Post: Antibody
  [NEEDS INFO] Map doesn't compile machine! 12 6,473 06-27-2013, 08:49 AM
Last Post: machine!
  [SOLVED] Sound doesn't work machine! 13 8,765 02-17-2013, 09:31 AM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-