Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
load issues (100%) while trying to start the server

#1
hey there, i ´m trying to bring up my own xonotic server on current ubuntu. so i cloned the xonotic/xonotic.git, updated, got the overkill mod and compiled the server.

now when i try to bring it up as dedicated server, i run into 100% load, get plenty of "program not loaded" lines and the server does not come up.

the tail of the server output looks like this:

Code:
client: program is not loaded
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk
Loaded private ID key_0.d0si for key_0.d0pk
Loaded public key key_15.d0pk [...]
there is already a signed private key for 0
SpawnServer: no map file named maps/_init/_init.bsp
execing server.cfg
"maxplayers" set to "20"
Host_Mingled: time stepped forward (went from 0.000000 to 1339687960.845915, difference 1339687960.845915)

notice the missing of the lines where ip and port are reported, it seems like the server is hanging there. would be great if someone could give me a hint.

-AB
Reply

#2
Oh wow, that's strange.

This here is not normal at all:
Code:
SpawnServer: no map file named maps/_init/_init.bsp

The server startup relies on this dummy map to load completely. Are you sure that all the needed repositories are cloned properly? Does ./all update show anything strange happenning? Try ./all checkout. You do have a clone of the map repo in data/xonotic-maps.pk3dir, right?
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
hey mr. bougo !

what i did:
Code:
git clone git://git.xonotic.org/xonotic/xonotic.git
cd xonotic
./all update -l best
./all compile -c -r dedicated

well, i find lots of files in the data/xonotic-data.pk3dir/ but i haven´t actually cloned the map repo you´re mentioning. isn´t the xonotic.git above containing all needed files?

i just updated again, recompiled. tail of what the compile output was:

Code:
+ /var/xonotic-git/xonotic/all update-maps
Found main repo = git://de.git.xonotic.org/xonotic/
Repository . enabled because it already exists
Repository data/xonotic-data.pk3dir enabled because it already exists
Repository data/xonotic-music.pk3dir enabled because it already exists
Repository data/xonotic-nexcompat.pk3dir disabled by default, create data/xonotic-nexcompat.pk3dir.yes to enable
Repository darkplaces enabled because it already exists
Repository netradiant enabled because it already exists
Repository div0-gittools disabled by default, create div0-gittools.yes to enable
Repository d0_blind_id enabled because it already exists
Repository data/xonotic-maps.pk3dir enabled because it already exists
Repository mediasource disabled by default, create mediasource.yes to enable
Repository fteqcc enabled because it already exists
fatal: Invalid object name 'HEAD'.
List of maps that got deleted (if any) and currently are in /var/xonotic-git/xonotic/data.old:
total 0

what about the invalid object name 'HEAD' ??
Reply

#4
Can you do ./all update and ./all checkout please? It seems your maps repo is broken, hence the git error message.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#5
Code:
+ cd /var/xonotic-git/xonotic/data/xonotic-maps.pk3dir
WTF? Not even branch master doesn't exist in data/xonotic-maps.pk3dir

checking the whole thing out again.
Reply

#6
Don't! You're wasting bandwidth on your link and on Xonotic's servers! You already have most of the data, you don't need to redownload everything.

Just remove xonotic-maps.pk3dir and run ./all update again. Or maybe even try ./all clean --reclone before doing that.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Opensuse Leap 15.1 and Server.cfg ldegroot 3 252 08-01-2019, 02:52 PM
Last Post: ldegroot
  LAN server console commands dbl 1 471 06-13-2019, 04:55 AM
Last Post: martin-t
  How to change server cfg on modified server veecho 4 713 04-24-2019, 08:15 PM
Last Post: BuddyFriendGuy
  Server error "Weapon stats writing failed: -404" FlufyBuny 1 363 04-13-2019, 04:36 AM
Last Post: It'sMe
  Dedicated server setup Rec0d 5 701 04-03-2019, 02:00 PM
Last Post: Rec0d
  South American Dedicated Server Professor 3 718 03-03-2019, 07:02 PM
Last Post: end user
Information [TUTORIAL] Xonotic Server behind OPNSense (and pfSense) gurbe 0 499 01-27-2019, 09:07 AM
Last Post: gurbe
  Xonotic server running behind UDP proxy not working doombringeroperator 2 702 01-07-2019, 02:23 PM
Last Post: doombringeroperator
  [NEED HELP] Server show on the browser list, but I can't connect! Professor 1 706 12-19-2018, 11:39 AM
Last Post: Professor
  Server Setup for Dummies litvinenkotea 7 4,487 12-08-2018, 01:20 PM
Last Post: tehjester78

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-