Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Server runs, but not right

I downloaded the server / edited the server.cfg / and I saved the server.cfg at Xonotic/data and .xonotic/data.
the server is running, but the Hostname is still
Xonotic 0.6.0 Server and the Gamemod is still dm /16 Player
(i changed these settings at the server.cfg e.g. Gamemod to lms)
when I add bots in the console-> no bots joind the game


Game is Xonotic using base gamedir data
Xonotic Linux 17:18:25 Mar 8 2012 - release
Current nice level is below the soft limit - cannot use niceness
Skeletal animation uses SSE code path
execing quake.rc
execing default.cfg
execing defaultXonotic.cfg
Warning: Could not expand $vid_width
Warning: Could not expand $vid_height
Warning: Could not expand $vid_pixelheight
execing sRGB-disable.cfg
menu: program is not loaded
execing weapons.cfg
Warning: Could not expand $r_showsurfaces
Warning: Could not expand $r_ambient
Warning: Could not expand $gl_finish
Warning: Could not expand $vid_gl20
Warning: Could not expand $vid_gl13
Warning: Could not expand $r_drawviewmodel
execing cdtracks.cfg
execing balanceXonotic.cfg
execing ctfscoring-ai.cfg
execing effects-normal.cfg
execing physicsX.cfg
execing turrets.cfg
execing unit_machinegun.cfg
execing unit_hk.cfg
execing unit_hellion.cfg
execing unit_mlrs.cfg
execing unit_flac.cfg
execing unit_fusreac.cfg
execing unit_plasma.cfg
execing unit_plasma2.cfg
execing unit_tesla.cfg
execing unit_phaser.cfg
execing unit_walker.cfg
execing unit_ewheel.cfg
execing vehicles.cfg
execing vehicle_racer.cfg
execing vehicle_raptor.cfg
execing vehicle_spiderbot.cfg
execing vehicle_bumblebee.cfg
execing crosshairs.cfg
execing commands.cfg
Warning: Could not expand $qport in alias _if_dedicated
execing _hud_common.cfg
execing _hud_descriptions.cfg
execing hud_luminos.cfg
couldn't exec config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
execing font-xolonium.cfg
Warning: Could not expand $scr_loadingscreen_barheight
Warning: Could not expand $scr_infobar_height
Warning: Could not expand $scr_centersize
This command only works on clients: cl_cmd hud scoreboard_columns_set
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk (fingerprint: Xon//KssdlzGkFKdnnN4sgg8H+koTbBn5JTi37BAW1Q=)
Loaded private ID key_0.d0si for key_0.d0pk (public key fingerprint: OsrSvSqFSsbZvBuztA+ZWJKKGDNkkS7DeoF29NCmN5c=)
NOTE: this ID has not yet been signed!
Only need a signature for an existing key...
Signature generation in progress...
Server using port 26000
Server listening on address
Server listening on address [0:0:0:0:0:0:0:0]:26000
execing server.cfg
Host_Mingled: time stepped forward (went from 0.000000 to 1344190333.930890, difference 1344190333.930890)
FS_OpenVirtualFile("data/maps/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("maps/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/autogenerated/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("maps/autogenerated/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/.ent", false): nasty filename rejected
FS_OpenVirtualFile("maps/.ent", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/.bsp", false): nasty filename rejected
FS_OpenVirtualFile("maps/.bsp", false): nasty filename rejected
Maplist contains no single playable map! Resetting it to default map list.
menu: program is not loaded
Server using port 26000
Server listening on address
Server listening on address [0:0:0:0:0:0:0:0]:26000
Error response from keygen server: Not allowed

thx sry for my bad english

Hello and welcome!

How do you add the bots in the console?

And what other languages do you speak? Maybe someone else speaks it too and can help, if you think that's more comfortable for you.

I add the bots at the console because it does not load the server.cfg.

I think server.cfg is loaded. Otherwise, it displays an error message.

Now, you should only place it in one of the two directories you said. Only place it in ~/.xonotic/data, not in Xonotic/data.

I want to know what command you typed to add the bots.

I used "setbots" to add bots. The command still doesnt work but i got the problem i has some problem with the forma of the server.cfg and the write/read premissions. (its a new server...) but thx for your help !

You need to add an argument after setbots: "setbots 1" to have one bot.

If there's an error in server.cfg, it should show up in the log.

If you want to add bots from server.cfg, you can set the bot_number variable to the number of bots you want.

Possibly Related Threads...
Thread Author Replies Views Last Post
  Latest Beta Server evit 1 420 04-02-2021, 04:06 PM
Last Post: end user
  Server does not start saddesad 2 314 11-25-2020, 04:39 AM
Last Post: saddesad
  [NEED HELP] Server failed to open socket on address... Hexactinal 2 337 11-21-2020, 04:28 PM
Last Post: Hexactinal
  Server Hosting Issue Saevus 3 959 11-11-2020, 02:53 PM
Last Post: :[:{b_e*r^f}:]:
  Docker Xonotic Dedicated Server ich777 15 3,447 10-08-2020, 11:15 AM
Last Post: BuddyFriendGuy
  BuddyFriendGuy Fun Server BuddyFriendGuy 22 8,837 10-08-2020, 11:14 AM
Last Post: BuddyFriendGuy
Rainbow Kotangєns' independent server Kotangens 2 652 10-07-2020, 05:08 AM
Last Post: L497
  RaspberryPi4 Server ablyveiled 2 1,051 08-19-2020, 10:36 PM
Last Post: ballerburg9005
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 2,661 08-19-2020, 10:17 PM
Last Post: ballerburg9005
  [SOLVED] I can't create my server. Kotangens 11 1,671 07-22-2020, 04:42 AM
Last Post: Kotangens

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-