Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server via UGCC?

#1
Anyone ever set up a xonotic server in UGCC?

I can run the bat file (windows server) and all is good, but having trouble getting it to actually run via UGCC.

Have it set up to run from the xonotic directory, and run server.exe with command line "-decicated +serverconfig server.cfg" …

says it's running, but it doesn't show up in the server browser (of the game)…

Also, when run that way, it doesn't show in the task list… so clearly it is not running…

Figured out how to capture output from this method of startup… this is what I get:

Code:
Game is Xonotic using base gamedir data
Xonotic Windows 03:08:14 Jun  5 2013 - release
Skeletal animation uses SSE code path
execing quake.rc
execing default.cfg
execing defaultXonotic.cfg
Warning: Could not expand $vid_width
Warning: Could not expand $vid_height
Warning: Could not expand $vid_pixelheight
execing sRGB-disable.cfg
menu: program is not loaded
execing weapons.cfg
Warning: Could not expand $r_showsurfaces
Warning: Could not expand $r_ambient
Warning: Could not expand $gl_finish
Warning: Could not expand $vid_gl20
Warning: Could not expand $vid_gl13
Warning: Could not expand $r_drawviewmodel
execing cdtracks.cfg
execing mutator_new_toys.cfg
execing balanceXonotic.cfg
execing effects-normal.cfg
execing physicsX.cfg
execing turrets.cfg
execing unit_machinegun.cfg
execing unit_hk.cfg
execing unit_hellion.cfg
execing unit_mlrs.cfg
execing unit_flac.cfg
execing unit_fusreac.cfg
execing unit_plasma.cfg
execing unit_plasma2.cfg
execing unit_tesla.cfg
execing unit_phaser.cfg
execing unit_walker.cfg
execing unit_ewheel.cfg
execing vehicles.cfg
execing vehicle_racer.cfg
execing vehicle_raptor.cfg
execing vehicle_spiderbot.cfg
execing vehicle_bumblebee.cfg
execing crosshairs.cfg
execing gamemodes.cfg
execing ctfscoring-samual.cfg
execing notifications.cfg
execing commands.cfg
Warning: Could not expand $qport in alias _if_dedicated
execing _hud_common.cfg
execing _hud_descriptions.cfg
execing hud_luminos.cfg
couldn't exec config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
execing font-xolonium.cfg
Warning: Could not expand $scr_loadingscreen_barheight
Warning: Could not expand $scr_infobar_height
Warning: Could not expand $scr_centersize
Warning: Could not expand $scr_centersize
This command only works on clients: cl_cmd hud scoreboard_columns_set
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk (fingerprint: Xon//KssdlzGkFKdnnN4sgg8H+koTbBn5JTi37BAW1Q=)
Loaded private ID key_0.d0si for key_0.d0pk (public key fingerprint: /EIPsutjbr9hSDKkVAnnQEQQDxTga3WJn5filSHT7lw=)
NOTE: this ID has not yet been signed!
Only need a signature for an existing key...
Signature generation in progress...
Server using port 26000
Server listening on address 0.0.0.0:26000
Server listening on address [0:0:0:0:0:0:0:0]:26000
Beginning notification initialization on SVQC program...
Notification initialization successful!
execing server.cfg
Host_Mingled: time stepped forward (went from 0.000000 to 1471650.218000, difference 1471650.218000)
FS_OpenVirtualFile("data/maps/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("maps/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/autogenerated/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("maps/autogenerated/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/.ent", false): nasty filename rejected
FS_OpenVirtualFile("maps/.ent", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/.bsp", false): nasty filename rejected
FS_OpenVirtualFile("maps/.bsp", false): nasty filename rejected
Maplist contains no single playable map!  Resetting it to default map list.
menu: program is not loaded
Server using port 26000
Server listening on address 66.225.232.194:26000
Server listening on address [0:0:0:0:0:0:0:0]:26000
Beginning notification initialization on a dedicated SVQC program...
Notification initialization successful!
Error response from keygen server: Not allowed

So it seems it reads the config, switches the port, then it goes back to 0.0.0's???

Will search and see if I can find something about the keygen error...
Reply

#2
(10-18-2014, 07:49 AM)Arbo Wrote: Anyone ever set up a xonotic server in UGCC?

I can run the bat file (windows server) and all is good, but having trouble getting it to actually run via UGCC.

Have it set up to run from the xonotic directory, and run server.exe with command line "-decicated +serverconfig server.cfg" …

says it's running, but it doesn't show up in the server browser (of the game)…

Also, when run that way, it doesn't show in the task list… so clearly it is not running…

Figured out how to capture output from this method of startup… this is what I get:

Code:
Game is Xonotic using base gamedir data
Xonotic Windows 03:08:14 Jun  5 2013 - release
Skeletal animation uses SSE code path
execing quake.rc
execing default.cfg
execing defaultXonotic.cfg
Warning: Could not expand $vid_width
Warning: Could not expand $vid_height
Warning: Could not expand $vid_pixelheight
execing sRGB-disable.cfg
menu: program is not loaded
execing weapons.cfg
Warning: Could not expand $r_showsurfaces
Warning: Could not expand $r_ambient
Warning: Could not expand $gl_finish
Warning: Could not expand $vid_gl20
Warning: Could not expand $vid_gl13
Warning: Could not expand $r_drawviewmodel
execing cdtracks.cfg
execing mutator_new_toys.cfg
execing balanceXonotic.cfg
execing effects-normal.cfg
execing physicsX.cfg
execing turrets.cfg
execing unit_machinegun.cfg
execing unit_hk.cfg
execing unit_hellion.cfg
execing unit_mlrs.cfg
execing unit_flac.cfg
execing unit_fusreac.cfg
execing unit_plasma.cfg
execing unit_plasma2.cfg
execing unit_tesla.cfg
execing unit_phaser.cfg
execing unit_walker.cfg
execing unit_ewheel.cfg
execing vehicles.cfg
execing vehicle_racer.cfg
execing vehicle_raptor.cfg
execing vehicle_spiderbot.cfg
execing vehicle_bumblebee.cfg
execing crosshairs.cfg
execing gamemodes.cfg
execing ctfscoring-samual.cfg
execing notifications.cfg
execing commands.cfg
Warning: Could not expand $qport in alias _if_dedicated
execing _hud_common.cfg
execing _hud_descriptions.cfg
execing hud_luminos.cfg
couldn't exec config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
execing font-xolonium.cfg
Warning: Could not expand $scr_loadingscreen_barheight
Warning: Could not expand $scr_infobar_height
Warning: Could not expand $scr_centersize
Warning: Could not expand $scr_centersize
This command only works on clients: cl_cmd hud scoreboard_columns_set
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk (fingerprint: Xon//KssdlzGkFKdnnN4sgg8H+koTbBn5JTi37BAW1Q=)
Loaded private ID key_0.d0si for key_0.d0pk (public key fingerprint: /EIPsutjbr9hSDKkVAnnQEQQDxTga3WJn5filSHT7lw=)
NOTE: this ID has not yet been signed!
Only need a signature for an existing key...
Signature generation in progress...
Server using port 26000
Server listening on address 0.0.0.0:26000
Server listening on address [0:0:0:0:0:0:0:0]:26000
Beginning notification initialization on SVQC program...
Notification initialization successful!
execing server.cfg
Host_Mingled: time stepped forward (went from 0.000000 to 1471650.218000, difference 1471650.218000)
FS_OpenVirtualFile("data/maps/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("maps/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/autogenerated/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("maps/autogenerated/.mapinfo", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/.ent", false): nasty filename rejected
FS_OpenVirtualFile("maps/.ent", false): nasty filename rejected
FS_OpenVirtualFile("data/maps/.bsp", false): nasty filename rejected
FS_OpenVirtualFile("maps/.bsp", false): nasty filename rejected
Maplist contains no single playable map!  Resetting it to default map list.
menu: program is not loaded
Server using port 26000
Server listening on address 66.225.232.194:26000
Server listening on address [0:0:0:0:0:0:0:0]:26000
Beginning notification initialization on a dedicated SVQC program...
Notification initialization successful!
Error response from keygen server: Not allowed

So it seems it reads the config, switches the port, then it goes back to 0.0.0's???

Will search and see if I can find something about the keygen error...

Those are for IPV6 so can be ignored I guess. Have you tried connection to the server manually by typing in the IP and Port in the address bar on the server list?

As for the keygen for some reason the server is refusing to give you one. Might have to wait till Monday I think to get another one assigned. But I think the server should still be listed but stats wont be recorded
[MoFo] Servers - North America - Hosted in Montreal Canada - Admin DeadDred [MoFo]
Reply

#3
Yeah, I was reading about the keygen thing. Seem a bit strange to me though, for if I run it from the batch file file it shows a different public key and runs fine, shows up in the server list, etc. Simply run it via ugcc which just calls the exe with the same parameters, different public key and this error. It's the same cfg file, same ip, port all that, so I'd think it would use the same key. Interesting.

Thanks for the response.
Reply

#4
How many key files do you have in the xonotic data folder? This would tell you if the game panel is trying to run a different session name under the same IP/PORT so the server is rejecting that key. If you ran the batch file manually first before running the server through the game panel then the Xon key gen server recorder that IP port for the first key. Now when its started from the game panel the game is trying to get a second key from the server but the server is rejecting that as theres already one assigned to that IP/Port.

If there is two sets of keys maybe you can back up them up and then rename the first one to the second one then start the control panel.
[MoFo] Servers - North America - Hosted in Montreal Canada - Admin DeadDred [MoFo]
Reply

#5
The keygen error is related to stats, not the visibility of the server.
Maybe check to see if port 26000 is open for UDP, and sv_public is 1 in server.cfg.

Also, the long string of 0s is an IPv6 address. Try turning that off and see if server stays up.

If it's still no good, try starting the game from command line with only the following command: xonotic-dedicated.exe
[Image: 230.png]
Reply

#6
will check in the data folder, thanks.

Yeah, the port is open and it runs fine from the stock batch file... and public is 1.
Reply

#7
Is 66.225.232.194 your IP address? Are you behind a NAT (for example a home router)?
Reply

#8
(10-19-2014, 01:36 PM)Mr. Bougo Wrote: Is 66.225.232.194 your IP address? Are you behind a NAT (for example a home router)?

That IP looks like i belongs to Velocity Servers.
[MoFo] Servers - North America - Hosted in Montreal Canada - Admin DeadDred [MoFo]
Reply

#9
That is the IP of our server... it goes direct out to the internet... many ports on it used for different game (servers)...
Reply

#10
Ah, you said something earlier about the server process not showing up. Can you give some more info about that?
Reply

#11
I'd say the best bet is to contact Masher at UGCC for control panel issues, he is always fast to help.
Regards!
MajorCarl
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Exclamation Error response from keygen server: Not allowed Debianita 8 7,223 05-13-2021, 05:45 PM
Last Post: cushinga
  RaspberryPi4 Server ablyveiled 3 1,166 05-13-2021, 04:30 PM
Last Post: cushinga
  Latest Beta Server evit 1 591 04-02-2021, 04:06 PM
Last Post: end user
  Server does not start saddesad 2 369 11-25-2020, 04:39 AM
Last Post: saddesad
  [NEED HELP] Server failed to open socket on address... Hexactinal 2 395 11-21-2020, 04:28 PM
Last Post: Hexactinal
  Server Hosting Issue Saevus 3 1,045 11-11-2020, 02:53 PM
Last Post: :[:{b_e*r^f}:]:
  Docker Xonotic Dedicated Server ich777 15 3,670 10-08-2020, 11:15 AM
Last Post: BuddyFriendGuy
  BuddyFriendGuy Fun Server BuddyFriendGuy 22 8,979 10-08-2020, 11:14 AM
Last Post: BuddyFriendGuy
Rainbow Kotangєns' independent server Kotangens 2 712 10-07-2020, 05:08 AM
Last Post: L497
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 2,946 08-19-2020, 10:17 PM
Last Post: ballerburg9005

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-