Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't compile my map

I can't seem to compile my map because it never creates a *.bsp. Here's the error log for -single bsp option in NetRadiant.

Here's the map itself:

Setting up
=== running build command ===
"/home/foobar/netradiant-20130630-ubuntu12-x86_64/q3map2.x86_64" -v -connect -game xonotic -fs_basepath "/home/foobar/Xonotic/" -fs_homepath "/home/foobar/.xonotic/" -fs_game data -meta -v "/home/foobar/.xonotic/data/maps/"
threads: 4
Q3Map         - v1.0r (c) 1999 Id Software Inc.
Q3Map (ydnar) - v2.5.17n-git-a7e6001
NetRadiant    - v1.5.0n-git-a7e6001 Jun 30 2013 22:35:59
Your map saw the pretty lights from q3map2's BFG
--- InitPaths ---
VFS Init: /home/foobar/.xonotic//data/
VFS Init: /home/foobar/Xonotic//data/

--- BSP ---
Creating meta surfaces from brush faces
WARNING: Unknown option "-v"
entering scripts/shaderlist.txt
entering scripts/shaderlist.txt (2)
entering scripts/shaderlist.txt (3)
entering scripts/alphamod.shader
entering scripts/common.shader
entering scripts/crystals.shader
entering scripts/decals.shader
entering scripts/effects_beam.shader
entering scripts/effects_forcefield.shader
entering scripts/effects_healpod.shader
entering scripts/effects_item.shader
entering scripts/effects_jumppad.shader
entering scripts/effects_lightning.shader
entering scripts/effects_warpzone.shader
entering scripts/ex2x.shader
entering scripts/exomorphx.shader
entering scripts/exx.shader
entering scripts/facility114invx.shader
entering scripts/facility114x.shader
entering scripts/glassx.shader
entering scripts/liquids_lava.shader
entering scripts/liquids_slime.shader
entering scripts/liquids_water.shader
entering scripts/logos.shader
entering scripts/map_catharsis.shader
entering scripts/map_courtfun.shader
entering scripts/map_darkzone.shader
entering scripts/map_g-23.shader
entering scripts/map_glowplant.shader
entering scripts/map_implosion.shader
entering scripts/map_leave_em_behind.shader
entering scripts/map_lightspeed.shader
entering scripts/map_newtonian-nightmare.shader
entering scripts/map_oilrig.shader
entering scripts/map_silentsiege.shader
entering scripts/map_solarium.shader
entering scripts/map_space-elevator.shader
entering scripts/map_stormkeep.shader
entering scripts/map_techassault.shader
entering scripts/map_xoylent.shader
entering scripts/metaltechx.shader
entering scripts/model_bigfan01.shader
entering scripts/model_crate02.shader
entering scripts/model_desertfactory.shader
entering scripts/model_lightspeed.shader
entering scripts/model_teleporters.shader
entering scripts/model_trak.shader
entering scripts/model_tree.shader
entering scripts/model_walker-static.shader
entering scripts/model_xonotic_jumppad01.shader
entering scripts/narmorx.shader
entering scripts/phillipk1x.shader
entering scripts/phillipk2x.shader
entering scripts/proceduralx.shader
entering scripts/screens.shader
entering scripts/skies_calm_sea.shader
entering scripts/skies_distant_sunset.shader
entering scripts/skies_exosystem2.shader
entering scripts/skies_exosystem.shader
entering scripts/skies_extragalactic.shader
entering scripts/skies_heaven.shader
entering scripts/skies_polluted_earth.shader
entering scripts/stein1x.shader
entering scripts/techpanelx.shader
entering scripts/terrain01x.shader
entering scripts/trak4x.shader
entering scripts/trak5x.shader
entering scripts/trak6x.shader
entering scripts/trak7x.shader
Script file scripts/domination.shader was not found
entering scripts/electro.shader
entering scripts/fireball.shader
Script file scripts/flags.shader was not found
entering scripts/hlac.shader
entering scripts/model-common.shader
entering scripts/onslaught.shader
entering scripts/portals.shader
Script file scripts/pyria.shader was not found
entering scripts/shotgun.shader
entering scripts/spiderbot.shader
entering scripts/teamfx.shader
Script file scripts/tree.shader was not found
entering scripts/tuba.shader
entering scripts/turrets.shader
entering scripts/weapons.shader
entering scripts/monsters.shader
entering scripts/ok_nade_counter.shader
     1286 shaderInfo
--- LoadMapFile ---
Loading /home/foobar/.xonotic/data/maps/
entering /home/foobar/.xonotic/data/maps/
WARNING: Couldn't find image for shader textures/NULL
Connection closed.

Help is highly appreciated!

EDIT: Apparently Spike managed to compile my map so it's probably something wrong with my NetRadiant installation.

I could compile it just fine as well.

I guess this line does not sound good: WARNING: Unknown option "-v"
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8 | #9


Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 1,028 03-29-2019, 11:19 AM
Last Post: Freddy
  [SOLVED] linux compile/link error BuddyFriendGuy 3 1,913 11-27-2017, 08:55 PM
Last Post: Lyberta
  [BUG] xonotic-maps ebuild does not compile ZyX 0 1,233 05-01-2017, 10:10 PM
Last Post: ZyX
  [SOLVED] Ubuntu 16.0.4 Compile RedScale12 8 3,443 09-06-2016, 08:40 PM
Last Post: RedScale12
  [SOLVED] cannot compile git code dingus 5 2,824 07-27-2016, 05:13 PM
Last Post: sev
  [SOLVED] Can't compile under OS X Yosemite BuddyFriendGuy 1 2,733 04-23-2015, 01:00 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] NetRadiant fails to compile with latest nvidia driver Maddin 6 4,170 03-25-2015, 06:02 AM
Last Post: Maddin
  [SOLVED] Map don't compile machine! 2 2,920 10-21-2013, 08:37 AM
Last Post: machine!
  [NEEDS INFO] Map doesn't compile machine! 12 7,482 06-27-2013, 08:49 AM
Last Post: machine!
  [SOLVED] how to compile linux and win executable using git under win7 TheGoodGamer 7 7,050 05-09-2013, 06:49 AM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-