Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Question about server and maps

#1
Question 
Hello all! I start played in Xonotic about 1 week. Recently I played in U1 – UT2004 (I dont like UT3), new UT 2015, Q3 Arena, Tribes: Ascend...

So now I invite my friends in game and we want to play by own server. Previously I hosted many time UT2004 server. Now what I see in Xonotic: in game I can start non-dedicated server, in game folder I found xonotic-dedicated.exe (P.S. my PC is x64) and "server" folder. When I start exe I noticed that server don't use config file. So I try it with files in server folder, I copy it into data folder, edit config and start bat file. Now I think server starting correctly (but console is empty), but I reach a problem: xonotic.exe autoshutdown if I start it. So I try to start another executors and xonotic-wgl.exe noticed me, that session lock and write path to this file.
Huh
So I confused, how I can start a game with server?
Also question: what is different between xonotic-wgl.exe and xonotic.exe? ( Idea It's a WebGL?)
————————————————————————————————————
Other problem I found first time on some server and later I fount this problem on default map (when I play singleplayer). Before this, my PC is powerful and Xonotic I setup by ultra settings. Now problem is overlight map, so much so that I see only white texture and players is also white. I record this video to show the problem (also I shown settings):

I don't know what is wrong on me, but on network map, where I see this bug first time people say that all good and don't see this overlight.
————————————————————————————————————
And final, I have 3rd problem that i called "black". Big Grin
This problem with only one server. When I start to play online, I start on DeFrag servers, because I want to learn better movement system, and I also love trials and team trials (teamwork) on UT2004. This problem with server (Prophets) Runaway from Devination [XDeFrag] 178.254.31.217:26001
At fitst time all matches is good, but leter all matches is black, fully. When I ask players, he says that all is good. I try to find a problem and I go to saves, in dlchache folder and I see: all maps, downloaded at this server is 0-byte files (no info). I delete this files and reconnect, but no happen, I also recieve 0 byte maps. This problem only with it server.

P.S. Question: Xonotic have own protocol? For example I can give link to UT2004 server like this: ut2004://178.254.31.217:26001 and UT start and connect to this server.
Reply

#2
Problem #2: Few maps have trouble with "Realtime world lighting" setting (e.g. Darkzone, Courtfun), just turn it off (r_shadow_realtime_world 0) and it should look fine.

Problem #3: That server has some broken downloads then, so it's kind of back luck. The other players had it downloaded already then. :/

and welcome Wink
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8 | #9

Reply

#3
(06-19-2015, 05:50 AM)XCanG Wrote: So I try to start another executors and xonotic-wgl.exe noticed me, that session lock and write path to this file.
Huh
So I confused, how I can start a game with server?

For your dedicated server, try this:
Code:
xonotic-dedicated.exe -sessionid a_session_name

Then for your client, you can either use a different session name, or just leave blank for a default.

(06-19-2015, 05:50 AM)XCanG Wrote: So I try to start
Also question: what is different between xonotic-wgl.exe and xonotic.exe? ( Idea It's a WebGL?)

Yes, one is SDL and the other own is GL. Some machines perform better in one than the other; they work mostly the same for me. Sometimes GL has a bit of glitch (again that depends on the system) so I mostly just use the SDL version. You can choose either one.

(06-19-2015, 05:50 AM)XCanG Wrote: So I try to start
And final, I have 3rd problem that i called "black". Big Grin

From time to time I have that same problem, too (mostly on GL). Sometimes I can solve it by deleting the bad map file (in the dlcache/ folder) that the client just downloaded (if you launch xonotic from the command line, you can see which file was downloaded in the console message), and reconnection will trigger a re-download. Other times it doesn't work and I just give up (because I don't want to delete everything in dlcache/, which likely will solve the problem). It happens rarely though.

I remember @Mario talking about this once in the game, so I believe the devs are aware of this problem.
Reply

#4
Thumbs Up 
BuddyFriendGuy, thanks, all is work.
Reply

#5
(06-19-2015, 05:50 AM)XCanG Wrote: .... This problem with server (Prophets) Runaway from Devination [XDeFrag] 178.254.31.217:26001
At fitst time all matches is good, but leter all matches is black, fully. When I ask players, he says that all is good. I try to find a problem and I go to saves, in dlchache folder and I see: all maps, downloaded at this server is 0-byte files (no info). I delete this files and reconnect, but no happen, I also recieve 0 byte maps. This problem only with it server.

P.S. Question: Xonotic have own protocol? For example I can give link to UT2004 server like this: ut2004://178.254.31.217:26001 and UT start and connect to this server.

First of all - Sorry 4 the late reply ...Tongue

All Prophets server were down for maintenance: -> Server Downtime

But all problems should be fixed

GreetZ Su
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  Server does not start saddesad 2 228 11-25-2020, 04:39 AM
Last Post: saddesad
  [NEED HELP] Server failed to open socket on address... Hexactinal 2 239 11-21-2020, 04:28 PM
Last Post: Hexactinal
  Server Hosting Issue Saevus 3 858 11-11-2020, 02:53 PM
Last Post: :[:{b_e*r^f}:]:
  Docker Xonotic Dedicated Server ich777 15 3,188 10-08-2020, 11:15 AM
Last Post: BuddyFriendGuy
  BuddyFriendGuy Fun Server BuddyFriendGuy 22 8,577 10-08-2020, 11:14 AM
Last Post: BuddyFriendGuy
Rainbow Kotangєns' independent server Kotangens 2 583 10-07-2020, 05:08 AM
Last Post: L497
  RaspberryPi4 Server ablyveiled 2 955 08-19-2020, 10:36 PM
Last Post: ballerburg9005
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 2,448 08-19-2020, 10:17 PM
Last Post: ballerburg9005
  [SOLVED] I can't create my server. Kotangens 11 1,499 07-22-2020, 04:42 AM
Last Post: Kotangens
Information [SOLVED] Server stops when I close command prompt on my PC Jewel 2 692 06-01-2020, 07:11 AM
Last Post: Jewel

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-