Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[BUG] Command line typing issues

About every other time I start Xonotic, the command line responds to certain letters as arrow, enter and other keys - instead of letters. For instance, Q is enter, F searched command history, N does nothing. Sometimes it works fine after restarting but the next time I play, the problem returns.

I am running:
Xonotic 0.8.2
Ubuntu 16.04

Sounds like your config file might be corrupt.

Go to ~/.xonotic/data and move autoexec.cfg and config.cfg to a temp directory outside the ~/.xonotic directory, then re-run Xonotic.

A set of bash commands that will do that for you (created a directory called 'xontmp' in your home dir):

mkdir ~/xontmp
mv ~/xonotic/data/autoexec.cfg ~/xontmp
mv ~/xonotic/data/config.cfg ~/xontmp

  1. If you don't have an autoexec.cfg that's fine. Some people do, some don't.
  2. I don't recommend deleting the files as then you can't put them back (or compare them to defaults to see what was wrong).
  3. This will reset your name, key bindings, etc. You won't lose your Xonstats identity though.
  4. There's a few servers out there that like to try and put garbage into your configs, so if this fixes it, I'd watch what servers you play on!
[Image: 21975.jpg]

Quote:“To summarize the summary of the summary: people are a problem.” - Douglas Adams

Is it possible that your "Ctrl" key is stuck? Afair "Ctrl+F" should search your command history (I'm not sure about the other keys you mentioned).

Does this happen with both -sdl and -glx? Maybe there's a problem in the backend libraries.

No autoexec.config file. Any other solutions? @Freddy thank you but ctrl key is not stuck.

There's 2 possible files as I mentioned. autoexec.cfg isn't always there (this depends on your setup). There's also config.cfg which by default IS present.

Xonotic loads autoexec.cfg if it exists, then it loads config.cfg.

In the config files you can bind keys to other meanings than their default.

  1. They're *.cfg files, not *.config files. The game only uses files ending in *.cfg (usually).
  2. The only other thing is to check you haven't enabled some different keyboard map in Ubuntu when launching the game. I know it's possible but never done it myself.

Edited to add:

Re-reading your first post, do you mean that this happens WITHIN Xon, or that after you've run (and quit) Xon, that this happens in a terminal/Xterm?

If it's happening in the terminal, then you might want to look into the terminal settings to check the enabled options. Some terminals (eg: Gnome Terminal) have menu options and an option to "reset" or "reset and clear" the terminal which might help too.

You might also be activating the Ubuntu equivalent of Window's "Sticky Keys" while in Xon playing a game (which would make Ubuntu think a key is stuck down). You'd need to look through your Ubuntu settings to see if that's enabled or how to turn it off.
[Image: 21975.jpg]

Quote:“To summarize the summary of the summary: people are a problem.” - Douglas Adams

I found the config.cfg file in the .xonotic hidden directory. After moving the file and forcing it to regenerate I have had no issues. I restarted Xonotic several timeS and the command input seems to work now. Thank you for help!

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Menu freezes when typing server address, old bug? MeLikeyTacos 2 1,582 10-21-2021, 09:59 PM
Last Post: MeLikeyTacos
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 9,537 04-19-2018, 02:42 AM
Last Post: cefiar
Bug [BUG] Permission Denied line 131 Ubuntu 14 ilyasofficial 2 3,151 10-22-2017, 06:39 AM
Last Post: martin-t
  [NEEDS INFO] lsmaps command -maniac|Su- 4 2,738 03-29-2017, 05:17 PM
Last Post: cefiar
  [SOLVED] How does the defer command work? nightspawn9911 4 3,645 07-18-2016, 07:34 PM
Last Post: nightspawn9911
  [SOLVED] Demo issues 0.8.1 Totally_Cool 2 3,225 06-03-2016, 12:45 PM
Last Post: Totally_Cool
  [BUG] Having some serious issues here Lee_Stricklin 8 8,957 01-24-2015, 12:55 AM
Last Post: Mario
Sad [NEED HELP] Connection issues/ Inactive netstat Totally_Cool 0 2,558 12-23-2014, 11:56 AM
Last Post: Totally_Cool
  [NEED HELP] Tearing issues since last update Halogene 0 3,191 01-16-2014, 05:28 AM
Last Post: Halogene
  [NEEDS INFO] 5.1 support and other issues with running under Windows 8 Lee_Stricklin 10 11,933 06-13-2013, 02:09 PM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-