Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] Keybindings not recognized when using the SDL launcher

I'm using Xonotic 0.8.2 on Arch linux installed from the repositories.
When I use the SDL launcher, there are several keys that aren't recognized but are recognized with the GLX launcher. So far, I have noticed:
  • Mouse wheel tilting (on GLX is recognized as MOUSE4 and MOUSE5) Using xev (the X event tester) they seem to be recognized by linux as button 6 and button 7
  • º key (under the Esc key, spanish keyboard layout) The GLX menu doesn't draw the key, but in the config.cfg appears as bind º "toggleconsole" and the key works in game. Using xev (the X event tester) it seems to be recognized by linux as keycode 49 (keysym 0xba, masculine)
I don't use the GLX launcher because it seems to have issues with pulseaudio, sometimes in game the audio stops until I restart the game.
Just in case it's important, it's not a fresh install, I have changed my compoter components but I have kept the hard disks and I have not reinstalled the OS nor Xonotic.

Any ideas on what may be happening?

By the way, any ideas on the GLX issues with the audio?

The issue may be related to Darkplaces Bug #133 although in that bug the mouse buttons are recognized (but with a different ID), here in SDL they aren't.

I tried the autobuild package, not the one generated by misc/tools/rsync-updater but an Arch package that gets the code from rsync://, and, at least the mouse problem persists.

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Add Bots using Console in Xonotic OpenSourceGames 1 7,924 08-09-2019, 10:16 AM
Last Post: martin-t
  [SOLVED] Character Using Wrong Sounds Castor 0 1,769 05-24-2018, 07:23 PM
Last Post: Castor
  [BUG] SDL version not loading, glx version buggy rendering Halogene 3 3,737 10-19-2017, 06:04 AM
Last Post: Freddy
  [NEED HELP] Low FPS when using FullScreen mode TheLastCrawler 0 2,464 09-06-2015, 10:02 AM
Last Post: TheLastCrawler
  [SOLVED] Little resolution issue since using Xonotic 0.8.1 N1mbus 4 4,633 09-03-2015, 02:34 PM
Last Post: N1mbus
  [SOLVED] sdl.dll missing wind8.1 maek234 4 5,649 07-05-2014, 04:15 AM
Last Post: Mr. Bougo
  [SOLVED] how to compile linux and win executable using git under win7 TheGoodGamer 7 10,149 05-09-2013, 06:49 AM
Last Post: Mr. Bougo
Wink [SOLVED] What is the difference between SDL and GLX client? unfa 9 31,377 02-28-2012, 01:55 PM
Last Post: Droid
Video [BUG] [Bug]no damage with using Electro with lightning gun mode Lento 2 3,598 02-28-2012, 11:04 AM
Last Post: Lento
Bug [SOLVED] Some comments on output from self-compiled SDL client Gallaecio 4 6,209 09-11-2011, 11:24 AM
Last Post: divVerent

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-