Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Net radiant on Mac OSX, how?

are you in the netradiant dir? you need to be in the netradiant dir.
Master of mysterious geometries

Imgur Gallery

Oh, cd netradiant, duh...
YES! Big Grin Running! Smile Darn, already gave you a +1 rep Wink

I did have to set my path when I opened up, no biggie, and this was in red when I opened Radiant:

Unable to find default tag file /Users/Name/xonotic/netradiant/install/ No tag support.

Is it a big deal?

mine does that too, and so far I haven't had any major problems because of it.

happy mapping Smile
Master of mysterious geometries

Imgur Gallery

Uh,.. crap...
Faild to get a listening socket on port 39000.
Try running with Build monitoring disabled if you can't fix this.

...Whenever I try to compile something, even minimap. What is build monitoring and how would one disable it?

I sometimes get that. so far, the only solution I can find is to restart the computer.

the "real" solution is to kill q3map2, but I haven't been able to figure out how to do that.
Master of mysterious geometries

Imgur Gallery

meh still don't get it, I can't find

@kay, theShadow was telling me how to install the real thing, not the gorilla weld. Maybe I'll make a full tut later.

I think q3map2 shuts down after awhile, my computer slept over night (NetRadiant and Xquartz quitted) and it worked fine in the morning. Also this might help on how to kill q3map2:

I am almost done with the tut, will try to upload soon.

PS were do you get all the models? (like the rail on reflection, green crates on aqueous, etc.)

Alright, here is the tutorial on how to install Xonotic GIT and then NetRadiant on Mac. Beware, I don't know much about this stuff this is just what I've managed to gather on the forums/internet, also most of part 2 is what theShadow said.

Good luck kay.

spawn a misc/model entity, and go to the model's folder in the xonotic-maps.pk3dir. then just look around. also, be sure to check cycle through the different model formats to read for, or you won't see all of them. (I really wish there was a way to view all model formats.)
Master of mysterious geometries

Imgur Gallery

I added warpzones to a map, but then deleted them cause they were in the wrong place, and added new ones. Then when I compiled and tried to run the server crashes and the console says:
======server ERROR in WarpZone_InitStep_UpdateTransform:
cannot infer origin/angles for this warpzone, please use a kill target or a trigger_warpzone_position

server EDICT 171:
absmin   ' -1.0000 -1.0000 -1.0000'
absmax   ' 1.0000 1.0000 1.0000'
solid    1.0000
classname    trigger_warpzone
effects    8192.0000
scale    1.0000
warpzone_isboxy    1.0000
SendFlags    16777215.0000
SendEntity    WarpZone_Send()
wapzone_next    entity 170
Host_Error: server: Program error in function Warpzone_InitStep_UpdateTransform:
cannot infer origin/angles for this warpzone, please use a killtarget or a trigger_warpzone_position
Tip: read above for entity information

QuakeC crash report for server:
s127267: STORE_V    [='    0.0000    0.0000    0.000'],
s127268: STORE_V    [='    0.0000    0.0000    0.000'], GLOBAL4
s127269 CALL1    GLOBAL245
s127270: STORE_V    GLOBAL1
s127271: SUB_F    MOVE_NORMALS (=    0.0000], [='    0.0000    0.0000    0.0000'),
s127272: GOTO    s127275
s127273: STORE_F    (=cannot infer origin/angles for this warpzone, please use a killtarget or a trigger_warpzone_position), GLOBAL4
s127274: CALL1    GLOBAL209
    :WarpZone_InitStep_UpdateTransform : statement 192
    :Warpzone_StartFrame : statement 192
    :StartFrame : statement 19

What's weird is that after I got tired of trying to figure out killtargets and stuff, I just deleted the warpzones and recompiled and tried again, but the error persists.

EDIT: Solved.

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Running On Mac jpumroy 2 756 01-04-2024, 09:04 PM
Last Post: jpumroy
Question [NEED HELP] How to use textures for radiant(win version)? (solved) Kotangens 4 3,161 08-12-2020, 01:33 AM
Last Post: Kotangens
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 1,714 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 2,941 03-29-2019, 11:19 AM
Last Post: Freddy
  [BUG] Fkeys F-keys F keys not working Mac OS Sierra 0.8.22 Space Ace 8 4,443 10-02-2017, 10:04 PM
Last Post: Space Ace
  [NEED HELP] Mac OSX Crashing very often and randomly -MCSquare- 0 2,196 01-30-2016, 12:08 AM
Last Post: -MCSquare-
  [SOLVED] Trouble with launch Xonotic on Mac OS X kanatov 6 11,390 10-03-2015, 10:49 AM
Last Post: SomeGuy
  [SOLVED] Version 8.0 won't start on OSX Yosemite oger 12 15,132 07-04-2015, 12:28 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Xonotic 0.8 completely froze my Mac a few times Player110 0 2,157 06-23-2015, 02:16 PM
Last Post: Player110
  [SOLVED] net radiant - no textures Raxno 5 6,131 11-08-2014, 04:44 PM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-