Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Noob needs help running server.

#1
Hi! New to the game here, I hope this is the right board
Im trying to run a server on my personal Win10 PC. Ive done everything in the readme.txt, and when I run the batch file its just a black CMD screen. When I run Xonotic-dedicated, it shows my server.cfg settings and looks like its running, but my server never shows up in the directory and the ip it shows is just 0.0.0.0
And after I try to start the game I get "Session lock could not be acquired". Heres a video of everything Ive done (I make 2 copies to try running the .bat first, then another running xonotic-dedicated first)


If I figure this out, Im going to make a youtube video on how to set up a server so other new players can make one, so all help is appreciated, thanks!
Reply

#2
Okay so what happens is:
If you are playing Xon, then quit the Xon instance. Look in task manager if Xon or Darkplaces is already active. Xon can only start 1 instance.
So there is a way to start a game under a different session ID. I do not know how though.
Reply

#3
(06-28-2021, 11:45 AM)Ray1992xD Wrote: Okay so what happens is:
If you are playing Xon, then quit the Xon instance. Look in task manager if Xon or Darkplaces is already active. Xon can only start 1 instance.
So there is a way to start a game under a different session ID. I do not know how though.

Ah alright, makes sense. Can someone explain the batch file/xonotic-dedicated application? Do I run the batch file and leave it open if its just blank?w
Reply

#4
Solved! Using this guys helpful fix https://forums.xonotic.org/showthread.php?tid=8462
Not sure if its really 'fixed' or more like 'broken-into-place', but hey, it works!
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  I can't see my listen server on server list fnmain 1 632 10-07-2023, 07:28 AM
Last Post: Grimnack
  Server not visible on the server browser for others or me DankoLord 1 1,789 02-21-2023, 08:02 PM
Last Post: ballerburg9005
  [NEED HELP] Help Adding Custom Gametypes CarbonGhost 3 953 01-24-2023, 09:09 PM
Last Post: ballerburg9005
  Xonotic server running behind UDP proxy not working doombringeroperator 3 4,012 11-21-2022, 11:00 AM
Last Post: Zaphod
  BaI server | South American Xonotic server (located in Chile) z411 0 2,727 01-02-2022, 11:36 PM
Last Post: z411
  Full server tutorial start-2-finish with maps & config from live server xonotic.us.to ballerburg9005 0 7,820 09-03-2021, 10:21 AM
Last Post: ballerburg9005
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 4,935 08-19-2020, 10:17 PM
Last Post: ballerburg9005
  [NEED HELP] Server dont appear in server browser abslimit 0 2,561 03-15-2020, 04:13 AM
Last Post: abslimit
  How to change server cfg on modified server veecho 4 4,276 04-24-2019, 08:15 PM
Last Post: BuddyFriendGuy
  Running a config script when the server becomes empty? Notavi 3 2,661 08-18-2018, 12:10 AM
Last Post: BuddyFriendGuy

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-