Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] Trouble with setting up a non-local private server

= Trouble with setting up a non-local private server

I'm having trouble with setting up a non-local server, and overall extremely
confused about Xonotic's networking.

I want to be able to play Xenotic with a few friends on a private server, we
are not in the same network and we are not using the same OSes.

I can run a dedicated server with `xonotic-dedicated -sessionid testserver`,
and it launches fine and loads the configs from `~/.xonotic/data/server.cfg` as
expected, although I do get the error `Error response from keygen server: Not
allowed` every single time I run with the `-sessionid whatever` flag, but I can
still enter my server locally.

== What I want to do

I want my friends to be able to connect to my server by entering
`connect MY_PUBLIC_IP:PORT`. I have my router already forwarding a port to my PC's 26000
port (in UDP mode). I can always enter the server locally by opening xonotic and running

However, trying to connect from outside my network (`connect
MY_PUBLIC_IP:PORT`) causes nothing. No errors, no warnings, just nothing.

I'm extremely confused as to how xonotic even deals with servers, why is the
default IP address (another a null IP in IPv6)? The script
`` seems to be kinda useless as it just runs the x86_64 binary I
already have installed on my system and can run any time I want with

I really want to know where I'm messing up because I never had this sort of
issue with any game, is the process as straightfoward as "running the server on
localhost and just port-forwarding your friends to it" or am I missing
something crucial?

Below there's some extra information that might be useful. Thank you for your patience.

== Extra Info:

OS: Arch Linux (64-bit)
Xonotic Installation: done through package manager, version 0.8.2

`~/.xonotic/data/server.cfg` (Only non-comment lines for the sake of not being verbose):

sv_public 0
hostname "xonotic_boogaloo"
sv_motd "yes."
port 26000
bot_number 2

Note: The `sv_weaponstats_file` seems counter intuitive, wouldn't the // comment the URL out?

The `net_address` line may be unnecessary, as that is generally used for larger-scale servers with multiple IPs. Other than that, all I can suggest is to perform tests to make sure the UDP port is actually open on your router - possibly by using an online tool.

As for the keygen error; that is just related to stats reporting, and can safely be ignored for your purposes.
[Image: 230.png]

Possibly Related Threads…
Thread Author Replies Views Last Post
Question [NEED HELP] Own server FinBiteLeaf 3 1,050 12-08-2022, 09:25 AM
Last Post: FinBiteLeaf
  [SOLVED] Trouble unzipping cygiconv-2.dll on Windows 7 (0.8.5) papa 3 2,393 10-19-2022, 05:01 PM
Last Post: mrhip
  [NEED HELP] Setting rsync autobuild to "Xonotic-High" Danfun64 1 735 10-05-2022, 01:23 AM
Last Post: irisxerno
  [NEED HELP] Private server is not private HitCoder 1 744 04-15-2022, 03:45 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Menu freezes when typing server address, old bug? MeLikeyTacos 2 892 10-21-2021, 09:59 PM
Last Post: MeLikeyTacos
  Impossible to connect to the Xonotic 0.8.2 server NoBrain 3 1,563 06-16-2021, 02:23 AM
Last Post: nj
  [NEED HELP] Xonotic on RaspPI - Setting up fonts gilius 5 2,476 04-09-2021, 11:22 PM
Last Post: gilius
  [NEED HELP] Offensive Servername - Block Server? conidad 1 1,135 03-30-2021, 10:59 AM
Last Post: _para
  [NEED HELP] server denied rcon access ristiisa 3 1,461 11-20-2020, 09:53 AM
Last Post: ristiisa
  [NEED HELP] Decrease server log level falco 1 1,547 04-17-2019, 06:11 PM
Last Post: BuddyFriendGuy

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-