Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Downloading maps don't work. Everything's black (Xon Preview)

#1
Thumbs Down 
Hi! I was having this problem a lot before with Xonotic, but I think it's just too much of pain now. It makes playing almost impossible.

Anytime I connect to to a server I'm getting black screen with entities flying around. Maps won't download.

I was just on one server where another guy there wrote that he's downloading map, but I got connected to the server and saw blackness. Like my client didn't even try to connect.

Earlier I got adviced to delete xonotic/data/dlcache/[somemapsname].pk3 and restart the game, I got there, but the folder dlcache was almost empty. There were no map packages, only two files:

file:///home/unfa/.xonotic/data/dlcache/csprogs.dat.791220.41022
file:///home/unfa/.xonotic/data/dlcache/csprogs.dat.796080.12172

So I smell something bad about map downloding process. Also I think that it's not good that the game connect to a server without having map to show. It looks like a bug. New users will think that the game is broken Sad

Old ones know it already Big Grin

Does anyone know how to help me? I'll try re-downloading the Preview release and using a new copy, but I'm not sure if this will help.

Cheers!
I have just tested this with fresh 0.1.0 preview with default configuration and the problem persists.

I'm running Linux (KXStudio - similar to Ubuntu) if that can help.
I'm making Liblast - a FOSS online FPS game made with Godot 4 and a 100% open-source toolchain
Reply

#2
Had that problem with Nex and Xonotic too. Weird it's never been addressed.
Reply

#3
Are you sure the directory dlcache is writable and the filesystem it's located on has enough free space? Also, can you connect to the server again and show us the console output?
He can talk the talk, but can he caulk the caulk?
Reply

#4
I have that problems too, sometimes.

Try r_restart, half of the times that works, no idea what it does Tongue, but map is not black any more Smile
Moved to Mepper
Reply

#5
(02-26-2011, 04:49 AM)lda17h Wrote: Are you sure the directory dlcache is writable and the filesystem it's located on has enough free space? Also, can you connect to the server again and show us the console output?
In my case, the file system has over 20 GB free, and the directory is writeable (and gets written to most of the time with new pk3 files). I have no idea how to reproduce the problem because it seems random.
Reply

#6
You may be missing libcurl. Can you check the error messages at the top of the console?

*This reply was inspired by divVerent's case study in black map errors here.
"Yes, there was a spambot some time ago on these forums." - aa
Reply

#7
r_restart restarts the renderer iirc. it would maybe also try to reload the map.. but not redownload
He can talk the talk, but can he caulk the caulk?
Reply

#8
Well, it at least sometimes work Big Grin
Moved to Mepper
Reply

#9
Never had missing curl when this happened. Pretty sure the Windows version has it built-in too, and had the same problem with that recently, too.
Reply

#10
Thanks for your many words!

I'm gonna try some solutions from here, recently got the same sheeet in Nexuiz, which is weird. In Nexuiz it always worked well, maybe servers are (re)moving themselves to Xonotic?
I'm making Liblast - a FOSS online FPS game made with Godot 4 and a 100% open-source toolchain
Reply

#11
I have the exact same problem... It looks like data are not downloaded from the server (ANY server). That is also true for players models, all players are just colored boxes...

EDIT : the console output is : "cURL downloads FAILED, executing cl_begindownloads". It looks like curl has a problem with, for instance : http://samual.nexuizninjaz.com/curlstuff...nex_r1.pk3
This issue had been adressed with nexuiz, but as far as I know, it had been solved...
Reply

#12
I don't have this problem in GIT version and arch linux.
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  Game is downloading something during play NoobKilla 3 2,665 07-17-2023, 11:53 AM
Last Post: NoobKilla
  [NEED HELP] Models, items, and sky black after 0.8.5 update htsm92 0 715 08-15-2022, 07:34 PM
Last Post: htsm92
  [SOLVED] Black and transparent elements in old maps h0tc0d3 1 926 08-01-2022, 03:24 AM
Last Post: h0tc0d3
  [NEED HELP] My mouse binds do not work in GLX? FAF 5 1,736 07-29-2022, 08:39 AM
Last Post: FAF
Shocked [NEED HELP] Helps for a right way to create a xon server and/or create concise guides derrant 6 2,639 03-31-2021, 07:40 AM
Last Post: Antibody
  [SOLVED] Textures don't load at other side of warpzone bananovenc 6 3,099 06-11-2020, 12:56 PM
Last Post: bananovenc
  [SOLVED] No stats for the player Ubuntu 19.04 - just don't use the flathub version Fiorentino 2 3,135 04-20-2020, 07:42 AM
Last Post: Fiorentino
  [NEED HELP] cl_gunalign doesn't seem to work on some servers/maps Aguaumreal 2 2,572 09-10-2019, 03:42 AM
Last Post: Aguaumreal
  [NEED HELP] Buffs Don't Work 3agle427 0 1,550 01-19-2019, 04:46 PM
Last Post: 3agle427
  [SOLVED] Servers list don't show any of servers Ketjow3 8 5,266 01-25-2018, 04:12 AM
Last Post: Ketjow3

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-