Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] server setup issue

Hi everybody,

I'm trying to mount a public server.

My problem: I managed to mount the server only once. I then managed to join it. But, when I stopped it, then restarted it, the server never didn't appear in the list anymore.
I also tried to reboot in the meantime, but the problem remains.

What I did: I just took the default server.cfg, put it in my \My Games\xonotic\data, and just modified the server name and sv_server 1.
I launched the .bat from C:\Program Files\xonotic-autobuild-downloader\Xonotic. Xonotic.exe is then launched successfully.

My config: Windows Vista, latest autobuild-downloader Xonotic version.
All firewall and antivirus off.

Anyone an idea?

Do you have a router? If so, have you forwarded the port of the server ?

Perhaps you could pastebin the config you use at the moment, along with whatever the server console might try to tell you?
"Yes, there was a spambot some time ago on these forums." - aa

(06-03-2011, 08:55 AM)Rage_ATWM Wrote: and just modified the server name and sv_server 1.

I hope you meant sv_public instead of sv_server?

Remove your passwords before pastbining your server.cfg Wink

If it helps, below is a copy of my Nexuiz server configs. "vcall kh" and "vcall ctf" are quite useful.

PHP Code:
sv_public 0    // 0 if the server should not be on the public servers list

hostname "Space_Man's test Server #2"    // this name will appear on the server list (the $g_nexuizversion gets replaced with the current version)

maxplayers 15    // number of players allowed on the server
port 26000    // the port used by the server
log_file "server.log"    // server console output will also be copied to this file. This: "${serverconfig}.log" uses variable substitution to make the logfile have the same name as your config file with .log appended which is useful if you run several servers

// List of maps to play on the server.  Set to "" to autodetect (which would enumerate ALL maps.  Maps that don't support the current game mode will be skipped, so you don't need to remove them here.
g_maplist ""
g_maplist_shuffle 1    // 0 always selects the next map out of g_maplist (but then better set g_maplist_votable 0 below to prevent repetitive votes), 1 will select random maps each time

// TEAMS for key hunt (change this to 2, 3, 4 to set a fixed keyhunt style)
g_keyhunt_teams_override 2    // teams for KH

// GAME MODE: what type of server do you want to host?
// possible values: dm (deathmatch), tdm (team deathmatch), dom (domination), ctf (ctf), rune (runematch), lms (last man standing), arena (arena), kh (keyhunt), as (assault), ons (onslaught), race (race), nexball (nexball)
gametype "ctf"

rcon_password "abc"

bot_number 0    // number of bots to add
skill 15    // the bots skill level
skill_auto 1
minplayers 4

g_maplist_votable 6    
// number of maps to vote between.  set to 0 to disable the map voting screen (please enable g_maplist_shuffle above when this is enabled, or votes will be repetitive)
g_maplist_votable_suggestions 2    // number of suggestions to accept using the suggestmap command
g_maplist_votable_abstain 0    // when 1, people get a "don't care" selection in the vote screen
g_maplist_votable_nodetail 1    // when 1, people can't see how many voted for what (to thwart abusive "influential" first votes)

// see Docs/mapdownload.txt for more info
sv_curl_defaulturl ""    //fallback download URL

set g_start delay 0 // 15 // start delay

g_chat_mutecontrol_suppress 1
g_chat_mutecontrol_tell_player 1

bot_join_empty 0

"mentalspace EyeCancer_Cured greatwall_remix brokenworld_v3r2 dance gasolinepowered_v1r2 evil(space)ctf minimanq3_r3"

set sv_vote_commands "ctf kh restart fraglimit chmap gotomap nextmap endmatch reducematchtime extendmatchtime allready kick cointoss movetoteam_auto" "these commands can be voted"
alias kh "exec kh.cfg"
alias ctf "exec ctf.cfg" 

PHP Code:
gametype "ctf"
minplayers "4"
bot_number 0
skill 13
skill_auto 1

"mentalspace EyeCancer_Cured greatwall_remix brokenworld_v3r2 dance gasolinepowered_v1r2 evil(space)ctf minimanq3_r3"
timelimit -

PHP Code:
gametype "kh"
minplayers "6"
bot_number 0
skill 13
skill_auto 1
g_keyhunt_teams_override 3 
// to do: choose 3 random teams from the list
g_maplist "aggressor Altairs_v2 ancient_v1r1 aneurysm bleach Blockscape Cleaner davesbonustower dieselpower Eyecancer_Cured facing)modes_v1r1 gasolinepowered_v2r3 runningman_1on1remix runningmanctf silvercity skyway stormkeep2"
timelimit -

'Sv_public 0' at the top of your config should read 'sv_public 1' if you want your game to show in the list.

What I just would like to do is make the server publically visible. I will tweak it afterwards.

As for the server.cfg, i use the exact default one I found in /xonotic/server. I just modified the hostname field and sv_public 1.

When I launched the .bat, i got in the console:
Game is Xonotic using base gamedir data
Xonotic Windows 01:11:21 Jun  2 2011 - release
Loaded public key key_0.d0pk (fingerprint: Xon//KssdlzGkFKdnn
Loaded private ID key_0.d0si for key_0.d0pk (fingerprint: P8h
Skeletal animation uses SSE code path
execing quake.rc
execing default.cfg
execing defaultXonotic.cfg
Warning: Could not expand $qport in alias _if_dedicated
Warning: Could not expand $r_showsurfaces
Warning: Could not expand $gl_finish
execing cdtracks.cfg
execing balanceXonotic.cfg
execing ctfscoring-ai.cfg
execing effects-normal.cfg
execing physicsX.cfg
execing turrets.cfg
execing unit_machinegun.cfg
execing unit_hk.cfg
execing unit_hellion.cfg
execing unit_mlrs.cfg
execing unit_flac.cfg
execing unit_fusreac.cfg
execing unit_plasma.cfg
execing unit_plasma2.cfg
execing unit_tesla.cfg
execing unit_phaser.cfg
execing unit_walker.cfg
execing unit_ewheel.cfg
execing _hud_descriptions.cfg
execing hud_luminos.cfg
execing config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
Warning: Could not expand $vid_conwidth
Warning: Could not expand $vid_conheight
Warning: Could not expand $r_dynamic in alias _update_generic
execing font-xolonium.cfg
Warning: Could not expand $scr_loadingscreen_barheight
Warning: Could not expand $scr_infobar_height
Warning: Could not expand $* in alias scoreboard_columns_set
Invalid program name client !
client program not loaded.
couldn't exec autoexec.cfg
there is already a private key for 0
Server using port 26000
Server listening on address
Server listening on address [0:0:0:0:0:0:0:0]:26000
After that, i got a long list of map-related warning messages.

Does this help?

Another thing: I use an internet box and I have both a local IP and a dynamic WAN IP.
All this could be source of some problem I guess.
Is it? If so, how could I overcome this?

Who said I'm a noob!!??

Rage_ATWM Wrote:Another thing: I use an internet box and I have both a local IP and a dynamic WAN IP.
All this could be source of some problem I guess.
Is it? If so, how could I overcome this?

It's a good bet that it's the router then. Have you forwarded the necessary ports (in this case port 26000) on your router?

If you're looking for the router config page, it's usually at It should be pretty self explanatory from there.
[Image: vN3NkMA]
(Idea stolen from Mr. Bougo. Hehehehe)

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Setup Dedicated Server to DL from Map Server mrhip 1 586 10-16-2023, 06:22 AM
Last Post: Freddy
  [SOLVED] Weird key hold issue with official version Bloodthorn 9 5,269 05-21-2018, 07:56 AM
Last Post: Bloodthorn
  [NEED HELP] Server Not Showing Up on Server Browser Antares* 5 4,477 05-21-2017, 04:46 PM
Last Post: martin-t
Question [NEEDS INFO] Multiplayer connection issue Adrint 18 11,893 06-20-2016, 01:37 AM
Last Post: BuddyFriendGuy
  [SOLVED] Little resolution issue since using Xonotic 0.8.1 N1mbus 4 4,799 09-03-2015, 02:34 PM
Last Post: N1mbus
  [SOLVED] Wierd rendering issue Ogger73 3 4,160 05-24-2015, 05:13 AM
Last Post: Mirio
  [NEED HELP] Weird Display Issue w/ Benchmarking Autobuild gamingwithnetbooks 2 3,933 11-13-2014, 08:35 AM
Last Post: gamingwithnetbooks
  [SOLVED] Ubuntu 12.04 Install Issue Red Viper 6 8,141 03-08-2014, 03:20 AM
Last Post: Halogene
  [BUG] Mac OSX 10.9 (Possibly 10.8 as well) Video Issue sirdavesmith 0 3,170 10-24-2013, 09:07 AM
Last Post: sirdavesmith
  [SOLVED] Little issue concerning video Mk 12 11,572 08-19-2013, 07:57 AM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
2 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-