Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Got the netradiant prob.

#1
Everything worked fine. I made a map, basic two floores, a bit of items on it and I had it all saved.

Now Im launching Netradiant, opening my map file and there is nothing out here! Completly NOTHING! No brushes! I didn't delete my map! its still there, but for some reason I can't open it!
Radiant is refusing to load my map! Also autosave has nth in it!
Somebody help!!!

Im afraid "areo themes" are involved in this shit.
Reply

#2
Look through the filter settings - haven't you accidentally filter "world" (alt+1) ?
Also, I'd look for the "use laternative texture projection" setting in preferences.
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#3
These settings are ok. No filters. how to reset all settings? back to default?
What if the problem is not with softwarebbut in the map code?
Reply

#4
That rarely happens. If you're exactly sure, it's not a setting problem, you might want to post somewhere the map file, so we can take a look at it.
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#5
http://ompldr.org/vYjh0bA]http://ompldr.org/vYjh0bA

BUT other mpas ain't display either, so its netradiant issue! How to restart all settings?
Reply

#6
Open the map file in an advanced text editor, and search replace:

#QNAN ->0

That'll solve your problem.
I've also poked divVerent about the issue. He said, it might be a bug in some tools, could you please get in touch with him, so you can debug this? Join the development #xonotic channel at freenode, and ask him about the issue!
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#7
NaNs may indeed be caused in some cases, and they fail to load back. We COULD detect them when writing, but then it's already too late anyway.

What we really need, is finding out which editing operations caused them in the first place, and fixing these.

@Justin: while editing the map, did you - at any time - witness a brush suddenly disappearing or stretching into infinity without you wanting that to happen? What were you doing then?
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#8
C.Brutail: Thank you very much. It worked
divVerent: Yes, I had the "dissapearing" problem. In the map there was a wall and after building it - the wall was also in game, BUT again : for no reason THE SAME wall wasn't displayed in Netradiant! (there were just a hole, where normally should be a wall). I can't really remind when precisely it vanished, but that was odd.
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
Rainbow NetRadiant-custom Garux 25 12,909 03-06-2024, 04:31 PM
Last Post: anoob
  Updated Xonotic gamepacks for NetRadiant and NetRadiant-custom SpiKe 2 1,951 06-25-2023, 06:02 PM
Last Post: anoob
  [NEED HELP] No Spawn Point In NetRadiant Map daspeller 0 24,968 10-19-2022, 07:22 PM
Last Post: daspeller
Information Updated NetRadiant builds illwieckz 7 8,120 06-29-2022, 02:33 AM
Last Post: illwieckz
  Can't get netradiant to work with Xonotic NoClue 2 2,522 06-14-2022, 01:25 PM
Last Post: NoClue
  [NEED HELP] Custom NetRadiant Textures / Textures Not Loading 3agle427 3 4,131 09-03-2021, 01:40 PM
Last Post: HIBANEZ
  Netradiant brush outline in 2D view grid mode Nyx 2 1,690 08-05-2021, 12:27 AM
Last Post: Nyx
  NetRadiant for Xonotic? Betaversion 3 2,511 12-22-2020, 02:35 PM
Last Post: Betaversion
  [NEED HELP] NetRadiant Models Not Working 3agle427 7 5,508 06-26-2020, 11:40 AM
Last Post: DarkFox
  [NEED HELP] NetRadiant Window 3agle427 4 3,357 01-11-2019, 08:54 AM
Last Post: Julius

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-