Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Compiling Xonotic from GIT-Repo under Windows.

Im trying to build Xonotic under Windows.
I`ve already downloaded the GIT-repo and everything, but I cant compile, as make isn´t a windows command.

Downloading make for Windows also didnt help much, I got the error "Unexpected token in "nexuiz""

Any Ideas? If someone explains it to me, Id also be willing to wright a guide and edit it into this post.

Edit: I set the path to the minigw and makeforwindows into the PATH Variable. Now I´m getting this error:
$ ./all compile
+ cd /f/Program Files (x86)/Xonotic/fteqcc
+ make
c:\X\GnuWin32\bin\make.exe: Interrupt/Exception caught (code = 0xc00000fd, addr
= 0x4227d3)

Im using the GIT Bash.


somebody on this forum has to know how to compile on windows, could you help please?

Whether it's SVN or GIT, it each time means you get an amount of data of the net and put it on your computer.

With the old SVN version, there was a command-line script that did it all for you.
This was the code in it:

@echo off

echo Setting up environment...
echo Long path name: %CD%

for %%f in ("%CD%") do set BASE=%%~sf
set PATH=%BASE%\bin;%BASE%\msys\bin;%BASE%\unxutils\usr\local\wbin;%BASE%\svn-bin;%BASE%\SDL\bin

cd %BASE%

echo Short path name: %BASE%

if exist run-wgl.bat ren run-wgl.bat run-wgl.dontrun
if exist run-sdl.bat ren run-sdl.bat run-sdl.dontrun

echo Downloading fteqcc...
call getsvn fteqcc
if errorlevel 1 goto bork

echo Building fteqcc...
cd fteqcc
if errorlevel 1 goto bork
copy /b fteqcc.bin fteqcc.exe
cd ..

set PATH=%PATH%;%BASE%/fteqcc

echo Downloading DarkPlaces...
call getsvn svn:// darkplaces
if errorlevel 1 goto bork

echo Building DarkPlaces...
cd darkplaces
make debug DP_MAKE_TARGET=mingw SDL_PREFIX="../SDL" CC=gcc
if errorlevel 1 goto bork
cd ..

echo Downloading Nexuiz...
call getsvn svn:// nexuiz
:call getsvn svn:// nexuiz
if errorlevel 1 goto bork

echo Building Nexuiz...
cd nexuiz\data
make FTEQCC="fteqcc" NEX_BUILDSYSTEM=1 clean all
if errorlevel 1 goto bork
cd ..\..

ren run-wgl.dontrun run-wgl.bat
ren run-sdl.dontrun run-sdl.bat

echo Done. You can double click run-wgl.bat or run-sdl.bat to start the game now!

goto end

echo An error has occurred (see above).


First it gets fteqcc and sets a PATH variable for it, then it gets darkplaces and does a "make debug". Then it gets the SVN repo. Then it uses fteqcc to build to whole thing.

Then you can run it via a .bat file that looks like this:

@echo off

cd nexuiz
set PATH=..\SDL\bin;misc\buildfiles\w32;%PATH%
..\darkplaces\darkplaces-sdl -nexuiz -mygames -condebug +cvar_check_default bypass
cd ..

So, someone with some more knowledge of commandline on windows than me should be able to do this.
[Image: di-712770583645.png]

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Windows 10 -basedir problem BlazedRasta 4 3,468 03-21-2023, 07:34 PM
Last Post: AlexVelasquez
  [SOLVED] Trouble unzipping cygiconv-2.dll on Windows 7 (0.8.5) papa 3 3,810 10-19-2022, 05:01 PM
Last Post: mrhip
Bug [BUG] strange checker pattern in the middle of explosions on Windows 10 fabzor3 2 2,035 09-23-2020, 08:38 AM
Last Post: fabzor3
  [NEED HELP] Compiling on Elbrus DJs3000 1 1,393 07-03-2020, 04:57 AM
Last Post: poVoq
  [NEED HELP] Netradiant compiling? Raxno 2 2,824 11-11-2017, 04:50 AM
Last Post: It'sMe
  [NEED HELP] video glitches in netradiant on windows 10 fabzor3 2 2,716 05-26-2017, 02:09 AM
Last Post: PinkRobot
  [TUTORIAL] How To Migrate accounts! (Windows) shanajer_ 1 2,022 03-06-2017, 06:09 PM
Last Post: -z-
Sad [NEED HELP] Help with compiling. ImSoAwesome 2 2,804 09-06-2016, 02:54 AM
Last Post: ImSoAwesome
  [NEEDS INFO] Apparently this game hates Xonar cards running under Windows 8 Lee_Stricklin 4 5,134 09-20-2014, 05:33 AM
Last Post: Lee_Stricklin
  [SOLVED] Locating Config file in windows 8 Racoon 3 4,988 02-09-2014, 11:08 AM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-