Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] RegisterNotification_Done error

#1
Hi, i can't join on half of the servers because to this error

http://i58.tinypic.com/2a7e6ag.jpg

I'm on Linux, it does not work on both glx and sdl.
Is there any way to fix that?
Reply

#2
I'll need more log. Don't post screenshots of your console, do a text dump and put it on pastebin.com for example, or in a code tag in this thread.

To do a dump, type in the console
Code:
condump crash.log
or any other filename. You'll find the log file in your data directory. If you don't know where that is, type
Code:
which config.cfg
If you're using linux, your data directory should be in $HOME/.xonotic/data/

Please let me know more about your situation too. What version of Xonotic are you using? What servers specifically are problematic and are not? Is it really "half the servers"?
Reply

#3
Sorry, didnt knew about that command.

Log file: http://pastebin.com/wMBSz6KQ

I'm using xonotic 0.7.0, downloaded from xonotic.org pressing the "Download Now!" button.

I can't connect to 3/4 of the servers, the only that works are:
[0.6.0] (DieTunichtguten.org)|{CTF Minsta+Hook}
[MoN] Overkill [MOD]
[MoN] Vehicle Gameplay
And some others.

The servers that i can't connect are for example:
Evil Ant Colony 0.7.0 CTF (Minsta & Hook) Server
(Prophets) Runaway from Divination [XDeFrag]
Super Mario Bros. USA
And almost all the others


I tried to rename the .xonotic folder, after doin that all the servers were working, then i tried to copy "config.cfg" from the old folder to te new .xonotic folder, and the problem has come back.
So i post you also that file (config.cfg) http://pastebin.com/G65Qc4LV seeing that the problem is there.

Thanks
Reply

#4
Okay. This is a compatibility bug related to your use of the italian language translation. Some notification items are malformed (contain a newline character at the end) and the verification code triggers a CSQC backtrace.

Because the checking code is in CSQC, and the CSQC code are sent by the game servers, that checking code varies depending on the server's version. This is what causes your problem. With your current config, you can only play on servers.

Here's what you can do:
  • Set the language to english
  • OR open the console and type:
    Code:
    notification_errors_are_fatal 0
    This might make the notification look strange due to an extra linebreak being present, but it shouldn't be too bad I think? If you try that, let me know.
  • OR get an italian translation file from our git servers. I'll make you a pk3 file for this in the next post because it involves overriding existing files due to name changes.
    EDIT: Nevermind, this last solution won't work, because 0.7.0 servers will then crash on you because your translation is *missing* the newlines. Pick one of the two solutions above.

EDIT: Thanks for the very helpful report by the way! I filed a bug report: http://dev.xonotic.org/issues/2017
Reply

#5
"notification_errors_are_fatal 0" worked with nothing strange enough to be noticed while playing, thanks!
Reply

#6
Yup, apparently the newlines are fixed by the same code anyway. Glad we figured this out! Have fun! Smile
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] linux compile/link error BuddyFriendGuy 3 2,011 11-27-2017, 08:55 PM
Last Post: Lyberta
  [NEEDS INFO] Custom map - Host Error: Mod_MAP_Mode: not yet implemented teratorn 6 2,908 03-07-2017, 04:29 AM
Last Post: SpiKe
  [SOLVED] Please help: -sessionid and an unique session name error anish01 2 3,362 05-10-2014, 03:30 AM
Last Post: Mr. Bougo
  [SOLVED] Quake Error "Video modes failed" on 2nd startup RpD 4 7,336 07-19-2013, 04:02 PM
Last Post: RpD
  [SOLVED] Parse error. aa 15 6,531 06-06-2013, 11:09 AM
Last Post: Maddin
  [NEEDS INFO] Netradiant crashing error korfi 4 3,046 05-31-2013, 02:08 PM
Last Post: korfi
  [SOLVED] NetRadiant startup error Smilecythe 11 6,189 02-16-2013, 12:49 PM
Last Post: Mr. Bougo
  [SOLVED] microsoft visual c++ runtime library runtime error raffi98 3 4,757 08-07-2012, 06:50 AM
Last Post: raffi98
  [NEEDS INFO] Error: "couldn't exec maps/courtfun.cfg" jackson4christ 11 8,473 12-05-2011, 08:15 AM
Last Post: divVerent
  [SOLVED] Error compiling DP after update GIT on linux Leeloo 2 4,051 06-01-2011, 08:26 PM
Last Post: Leeloo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-