Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] cannot compile git code

#1
I followed the instructions at https://gitlab.com/xonotic/xonotic/wikis...ory_Access to download and compile the most up-to-date version of the codebase. However, when I run ./all compile I get the following error:

Code:
/xonotic/../all.xonotic.sh: line 73: make: command not found

I'm wondering what it is that I could be doing wrong. The only commands I input were the ones listed on that tutorial page. Any ideas?

E: I'm not sure whether or not it is relevant but I am running windows 7 64 bit.
Reply

#2
What platform are you on? It seems you're on Linux, so
Code:
sudo apt-get install build-essentials
should do the trick.
Reply

#3
(07-22-2016, 12:48 PM)kaadmy Wrote: What platform are you on? It seems you're on Linux, so
Code:
sudo apt-get install build-essentials
should do the trick.

I am running windows 7 64 bit. Git-for-windows has a BASH emulator, but many of the commands don't work.

It doesn't recognize the sudo command you said to use.
Reply

#4
You might find more help on the developers IRC channel (irc://irc.freenode.net/xonotic).
I don't have experience with compiling Xonotic on Windows, but a few thoughts:

The Xonotic compilation is geared towards a Linux (Unix) environment.
On Windows, it is therefore necessary to install software that emulates this environment.
The error you encountered means that some of the tools (make) are not properly installed.

It appears to me that msysgit does not offer the entire toolset required
for the compilation, or you missed to include it during its setup.
To get all tools, you might need to install MinGW and set up the paths properly.
See for example: https://stackoverflow.com/questions/5648...gw-and-git
Reply

#5
(07-24-2016, 08:42 AM)sev Wrote: You might find more help on the developers IRC channel (irc://irc.freenode.net/xonotic).
I don't have experience with compiling Xonotic on Windows, but a few thoughts:

The Xonotic compilation is geared towards a Linux (Unix) environment.
On Windows, it is therefore necessary to install software that emulates this environment.
The error you encountered means that some of the tools (make) are not properly installed.

It appears to me that msysgit does not offer the entire toolset required
for the compilation, or you missed to include it during its setup.
To get all tools, you might need to install MinGW and set up the paths properly.
See for example: https://stackoverflow.com/questions/5648...gw-and-git

This was indeed the case. I jumped on irc and got some help. Everything is installed and working properly now.

Thanks for the help!
Reply

#6
Great to hear Big Grin

In case that others encounter the same issue in the future and find this thread,
it would be useful if you provide a quick summary of the solution.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 849 03-29-2019, 11:19 AM
Last Post: Freddy
  [SOLVED] linux compile/link error BuddyFriendGuy 3 1,753 11-27-2017, 08:55 PM
Last Post: Lyberta
  [BUG] xonotic-maps ebuild does not compile ZyX 0 1,127 05-01-2017, 10:10 PM
Last Post: ZyX
  [SOLVED] Ubuntu 16.0.4 Compile RedScale12 8 3,217 09-06-2016, 08:40 PM
Last Post: RedScale12
  [SOLVED] Source Code Xonotic on Ubuntu 15.04 Ryan 2 2,927 09-16-2015, 10:48 AM
Last Post: Beagle
  [SOLVED] Can't compile my map machine! 1 1,868 05-09-2015, 08:47 AM
Last Post: Mirio
  [SOLVED] Can't compile under OS X Yosemite BuddyFriendGuy 1 2,542 04-23-2015, 01:00 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] NetRadiant fails to compile with latest nvidia driver Maddin 6 3,987 03-25-2015, 06:02 AM
Last Post: Maddin
  [SOLVED] Map don't compile machine! 2 2,805 10-21-2013, 08:37 AM
Last Post: machine!
  [NEEDS INFO] Map doesn't compile machine! 12 7,257 06-27-2013, 08:49 AM
Last Post: machine!

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-