Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Cannot run game anymore after new git update

I played the game yesterday without issue but after executing "all checkout && all update" today, which succeeded as an operation without errors, I get the following when trying to launch the game now:
Game is Xonotic using base gamedir data
gamename for server filtering: Xonotic
Xonotic Linux 11:13:29 Jul 25 2018 - release
Current nice level is below the soft limit - cannot use niceness
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  153 (GLX)
Minor opcode of failed request:  3 (X_GLXCreateContext)
Value in failed request:  0x0
Serial number of failed request:  98
Current serial number in output stream:  99
real 0.06
user 0.04
sys 0.01
I already tried to execute "all clean" and then repeated the checkout and pull but this, while executing fine without errors, did not solve the issue.

Any ideas?

Edit: I execute the checkout and update commands almost every day before I play and I'm pretty sure that I did so yesterday before playing without issue, so if it has to do with the newest git update it must be commits that were made in the last 24 hours.

Did you do a system update (X11)? Reboot and try again.

(07-25-2018, 06:33 AM)It\sMe Wrote: Did you do a system update (X11)? Reboot and try again.

It seems I did Shy 

Rebooted and everything works fine again; thank you!

Possibly Related Threads...
Thread Author Replies Views Last Post
Question [NEED HELP] Certain maps crash my game :( flexo 4 1,464 12-07-2020, 09:25 AM
Last Post: Ecthelion
  [NEED HELP] cant start the game/ session lock problem skyghost47 1 873 10-24-2020, 11:50 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Sound dissapears mid game mastablasta 0 360 10-01-2020, 12:27 PM
Last Post: mastablasta
Exclamation [SOLVED] macOS Sierra: -basedir /path/to/game iqxonotic 11 33,595 09-09-2020, 02:04 PM
Last Post: dixius99
  [NEED HELP] Can't join anymore fenjrill 5 1,145 07-17-2020, 07:04 AM
Last Post: LegendGuard
  [BUG] The game seems doesn't recognize virtual 7.1 noctiveqc 2 991 02-17-2019, 02:10 AM
Last Post: martin-t
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 2 1,768 01-06-2019, 05:15 AM
Last Post: SpiKe
  [NEED HELP] Custom Game Modes 3agle427 5 1,670 12-30-2018, 12:44 AM
Last Post: Lyberta
  [SOLVED] Menu fails to load after recent update Bloodthorn 2 1,320 09-25-2018, 08:11 AM
Last Post: Bloodthorn
  [SOLVED] Game displays [x] joined the [y] team upon connecting Bloodthorn 3 1,429 09-17-2018, 01:52 AM
Last Post: Lyberta

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-