Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] net radiant ... just ... stopped working

#1
Exclamation 
...

for some odd reason net radiant decided to just stop compiling my maps for no apparent reason...

I was happily mapping and compile the map once perfectly ... then I tested it ... changed some things and compiled again ... it gave me this

(Test: -bsp, -vis, -light medium) -- note :: I almost always compile with this

This is the netradiant that came with the mapping support on beta.xonotic.org (i think that is what the address is) running on a quite recent autobuild (this week)

Code:
Setting up
Listening...
=== running build command ===
"/home/hutty/xon/xonotic-autobuild-downloader/Xonotic/mapping/netradiant-1.5.0-20110819/install/q3map2.x86" -v -connect 127.0.0.1:39000 -game xonotic -fs_basepath "/home/hutty/xon/xonotic-autobuild-downloader/Xonotic/" -fs_homepath "/home/hutty/.xonotic/" -fs_game data -vis -saveprt "/home/hutty/.xonotic/data/maps/lostless5005.map"
Connected.
threads: 4
Q3Map         - v1.0r (c) 1999 Id Software Inc.
Q3Map (ydnar) - v2.5.17n
NetRadiant    - v1.5.0n Feb 25 2012 17:53:00
Your map saw the pretty lights from q3map2's BFG
--- InitPaths ---
VFS Init: /home/hutty/.xonotic//data/
VFS Init: /home/hutty/xon/xonotic-autobuild-downloader/Xonotic//data/

--- Vis ---
saveprt = true
Loading /home/hutty/.xonotic/data/maps/lostless5005.bsp
************ ERROR ************
Error opening /home/hutty/.xonotic/data/maps/lostless5005.bsp: No such file or directory


Im running a rather new (this week) kubuntu install 11.10 ... kde 4.7

the only thing i did while mapping was watching a dvd ... which involved installing the dvd codec stuffs and VLC ... but I compiled successfully once after that .. so I dont think that is it.

... I went into the settings and clicked the rest button ... still didn't work

...I went back to the compile place and ran "make" again ... still doesn't work

linked is a screen shot ... and the .map file that "broke" it

map

screen shot

... it NO WERKY !!! >.<
Reply

#2
It seems to me that is jumping the "build bsp" part. Thats why it cant found it when trying to compile -vis.

Have you tried to compile .bsp only and then try to compile -vis?
Reply

#3
Off-topic, but I edited your post to change the php tag to code tags. The php tag colors php, and it's freaking unreadable.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#4
... oh ... i didn't see a code tag button.... php looked closest

single -bsp compiles fine

single -vis done right after single -bsp gets the same problem
Reply

#5
The code button is the #-looking one.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#6
It seems like your entity definition file is broken. You may compile Radiant again, that should help. Wink
Reply

#7
... re extracted netradiant form the archive and re make'd it ... compiled map (it can be any map) ... same problem

MAJOR EDIT !!!!

very disturbing news ... I ran q3map2 by itself ... and it "aborted" so ... its not netradiants fault ...

I posted my full konsole output here
link


There my be something very wrong ... especially for it to just stop working out of the blue like that
Reply

#8
... bump/doublepost...

I took a second look at the output ... it seems that it breaks at


*** buffer overflow detected ***: ./q3map2.x86 terminated


... i have no idea how to fix it
Reply

#9
Contact div about this by mail, I guess.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#10
Hmm, is it the newest NetRadiant? --> http://samual.nexuizninjaz.com/Xonotic-2...upport.zip
Reply

#11
i think it is (it had compile options for the new lighting system) ... i'll try your link though ....

EDIT :: nope ... didn't work ...

i'll probably contact div too
Reply

#12
It does not happen for me. Can you provide your exact input files?
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#13
... input files? ... what do you mean by that?
Reply

#14
.map and all other source files read by netradiant or q3map2.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#15
... so you want a zip of my entire .xonotic directory? ... and Xonotic's data dir? .... its kinda 2 gig ...

That would take several (5+) hours to uplode on my network ... and would fill up my ubuntu one account pretty fast

...
Reply

#16
Uh no, just the .map and other map files. I'm not a mapper, so I have no idea if shaders, object files etc. are used by q3map2 (for lightmaps or whatever, I don't know?). If there's anything more than the .map that influences the way the map is compiled, include that too.

EDIT: basically everything that one would need to compile the map and that isn't included in the xonotic repo. So that div can try to reproduce the bug in the same circumstances as you get it.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#17
well ... before bothering div again i decided to do a little resarch myself ... I cleared out my .xonotic directory of nay custom textures shaders models ... all the stuff i made

... and it worked ...

a simple test map did compile ... now i have to figure out what broke it

edit:: my current big map project is still having problems ... i may just have to restart it

edit2 :: the bad .map file is allready posted above .... before you ask for it again
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Spacebar not working on Erbium Deathmatch. Pallama 2 387 09-24-2019, 03:44 PM
Last Post: Pallama
  [BUG] Fkeys F-keys F keys not working Mac OS Sierra 0.8.22 Space Ace 8 1,475 10-02-2017, 10:04 PM
Last Post: Space Ace
  [NEEDS INFO] W key are not working in fedora24 linux akillah 2 1,756 03-06-2017, 08:35 PM
Last Post: -z-
  [SOLVED] Motion blur not working? Beagle 0 1,198 01-25-2016, 05:45 PM
Last Post: Beagle
  [SOLVED] net radiant - no textures Raxno 5 3,827 11-08-2014, 04:44 PM
Last Post: Mr. Bougo
Sad [NEEDS INFO] Xonotic is not working noambx 11 5,567 07-04-2014, 02:45 AM
Last Post: SpiKe
  [SOLVED] Stopped working after Kernel upgrade Indigo340 10 4,146 09-28-2013, 09:35 AM
Last Post: Indigo340
  [SOLVED] Motion Blur not working.. kojn^ 0 1,435 04-03-2013, 11:20 AM
Last Post: kojn^
  [SOLVED] netradiant still not working tangerian 19 9,191 11-01-2012, 12:55 AM
Last Post: hutty
  [SOLVED] net-radiant wont compile hutty 1 1,925 10-29-2012, 12:13 AM
Last Post: hutty

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-