Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] We need a FAQ item for the "black map" problem in maps with fog

Reply

#2
Actually, no. Fog was working well in 0.5. Somewhere, somebody broke it on the engine side between 0.5 and 0.6. This is a serious bug. We should find the commit that broke it - unfortunately, I can't help here, because I don't have this problem Sad

It already has a ticket on the bug tracker btw.: http://dev.xonotic.org/issues/1215
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#3
Augh. That means we have to teach somebody to use git bisect.
Reply

#4
This might have fixed the problem http://svn.icculus.org/twilight?view=rev&revision=11818
Reply

#5
Now that is odd. icculus has that commit, our own dakrplaces branches don't. oO Neither div0-stable nor master was updated since 2 weeks, so we cannot even test if the fix commited by divVerent works at all.
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#6
I hope this will be figured soon (though it never affected me, so I can't test it really). Next up, motion blur.
Reply

#7
(05-30-2012, 07:13 AM)C.Brutail Wrote: Neither div0-stable nor master was updated since 2 weeks, so we cannot even test if the fix commited by divVerent works at all.
Can you just do a diff of that revision versus current git to make a patch to test?

For future reference and search engines: This particular issue only comes up when OpenGL 2.0 is disabled. More of an issue on older and more broken graphics card drivers where OpenGL 2.0 may not be supported.

Another issue with the OpenGL 1.x paths currently is that warp zones do not render at all. This makes glowplant for example unplayable. Are the OpenGL 1.x paths tested frequently enough to be able to be fully supported?
I'm at least a reasonably tolerable person to be around - Narcopic
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [BUG] A font-rendering performance problem (of upstream DarkPlaces) NaitLee 11 761 08-20-2022, 01:23 AM
Last Post: NaitLee
  [NEED HELP] Models, items, and sky black after 0.8.5 update htsm92 0 218 08-15-2022, 07:34 PM
Last Post: htsm92
  [SOLVED] Black and transparent elements in old maps h0tc0d3 1 317 08-01-2022, 03:24 AM
Last Post: h0tc0d3
Question [NEED HELP] Certain maps crash my game :( flexo 6 2,747 01-17-2022, 08:55 PM
Last Post: flexo
  [NEEDS INFO] Deleting Old Unused Maps Space Ace 1 999 12-17-2021, 08:23 PM
Last Post: MusicGoat
Question [NEED HELP] Problem with charset of names in XonStat API NAPALM 0 509 11-11-2021, 08:38 AM
Last Post: NAPALM
  [NEED HELP] Netradiant, xonotic-mapping-support and maps dir? Gwlanbzh 1 919 02-02-2021, 06:57 PM
Last Post: AriosJentu
  [NEED HELP] cant start the game/ session lock problem skyghost47 1 1,886 10-24-2020, 11:50 PM
Last Post: BuddyFriendGuy
  [NEED HELP] cl_gunalign doesn't seem to work on some servers/maps Aguaumreal 2 1,900 09-10-2019, 03:42 AM
Last Post: Aguaumreal
  [NEED HELP] Windows 10 -basedir problem BlazedRasta 2 2,542 06-13-2019, 05:12 AM
Last Post: martin-t

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-