Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Bad resolution change! Stuck on black screen!

I changed my screen resolution in the game settings to try and get a better frame rate, but my screen is now black... I tried reinstalling the game but that didn't change anything.
I can't remember the screen resolution that I changed to, is there any way to reset the settings or remove the settings file and download a new default one?

What is your operating system?

You will have to either edit your configuration file by hand to disable fullscreen or launch the game in windowed mode.

In *NIX operating systems, the easiest way to go would be to launch the game by passing it the "+vid_fullscreen 0" argument from a terminal:
cd /path/where/the/xonotic/binary/is/
followed by
./ +vid_fullscreen 0
or, in Mac OS X,
open --args +vid_fullscreen 0

In Windows, you can do the same thing in the command prompt using the following:
xonotic-sdl.exe +vid_fullscreen 0
after getting into the right directory using the cd command.

You could also follow the instructions in this post but replacing -nosound and -nohome with +vid_fullscreen 0

You can also locate your config.cfg file and edit it with a text editor to change the vid_fullscreen line from 1 to 0 or change the vid_width and vid_height to the right resolution. But [b]please[b] don't use Notepad or Word in Windows to do that: I can't guarantee it will get the line endings right and you might screw up your config.cfg. The problem with that is that config.cfg's location (the personal data directory) depends on your OS and I can't tell for sure where that is. In Linux, it's in ~/.xonotic/data. In Windows, it's sometimes found in your User directory under "My Saved Games" or somesuch. That's all I know.

Another method is to type blind in the console. Load the game, wait for the music to start up then press Shift + Esc to bring down the console.

Then type:

vid_width 1024

...then press enter...

vid_height 768

...then press enter...


...back to defaults!

What resolution were you trying? What hardware and software are you using? It may be interesting to find out if there is some compatibility issue somewhere. A driver problem is a possibility here.
I'm at least a reasonably tolerable person to be around - Narcopic

Thanks guys, I got the problem solved, I used the blind console method.

The graphics card I use is an old nvidia geforce 7300 LE, my PC screen resolution is 1280 by 768 pixels, I have no idea if this is relevant, but there you go! ^.^
The resolution I tried on the game was either 720x576 or 720x480

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Models, items, and sky black after 0.8.5 update htsm92 0 715 08-15-2022, 07:34 PM
Last Post: htsm92
  [INVALID] Resolution can't be changed Majki 17 13,476 08-14-2022, 02:41 AM
Last Post: FAF
  [SOLVED] Black and transparent elements in old maps h0tc0d3 1 923 08-01-2022, 03:24 AM
Last Post: h0tc0d3
  [SOLVED] FPS Stuck at 60? Eile 3 2,701 07-27-2022, 04:11 PM
Last Post: FAF
  [NEED HELP] Can't set 2k resolution noteven 4 3,014 05-07-2021, 02:33 PM
Last Post: noteven
  [NEED HELP] Change mapinfo to make a CTF map a CTS map. Bhagwa-Yodhak-69 3 2,383 09-08-2020, 06:03 AM
Last Post: _para
  Change campaign last level beat permanently Pallama 2 3,434 02-07-2020, 02:22 PM
Last Post: DarkFox
  [NEED HELP] Xonotic change data directory Bla1 2 2,204 06-26-2019, 12:45 AM
Last Post: Bla1
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 1 3,144 01-06-2019, 05:15 AM
Last Post: SpiKe
  [NEED HELP] How to change dualshock gamepad sensitivity? NEOalquimista 2 4,218 09-04-2017, 11:25 AM
Last Post: It'sMe

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-