Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Trouble with .8 and map downloads

#1
Hello World!

I have installed an Arch linux server and install xonotic 0.8.
I then installed lighted and copied downloaded maps to the server directory.
I then links the maps to the /usr/share/xonotic/data directory. I added the sv_defaulturl = http://server/maps and I can download the maps from a browser. But when a client connects, not textures are downloaded and all I see is a black room with random objects.
Looking at the server console during that time I get an error:
Could not initiate autodownload due to URL buffer overflow
Does anyone have any ideas? all i can play are the standard maps built in....


{Resolution}
deleted all zz*.pk3 files on server.
Reply

#2
It's just a wild guess, but do you have curl installed?
[Image: 9074.png]
Reply

#3
Yes, it is installed on the server....
Reply

#4
How long are the URLs? Do you mind giving an example?
Reply

#5
I remember having a similar problem with similar error, in my case the problem was curl missing from my client.

Another quick hack until you figure it out is putting the maps that are on your server in the dlcache of your client directly.
[Image: 9074.png]
Reply

#6
Curl isn't missing here, though. It seems that the command that makes clients download requirements (serverpackages and maps I think) is too long, so the server doesn't send it.

kuedan, what do you get when you type sv_curl_serverpackages in your server console?
Reply

#7
Mr. Bougo, I typed that in the server console and i get "sv_curl_serverpackages" is "" [""]
Also, all the maps are were uploaded from my dlcache, so I already have them on the client.
The URL is the IP address/maps/*.pk3
on a side note, the reason I installed this on a fresh arch linux is because the cents 7 server i tried it on also did the same thing...
I appreciate your help, btw
Reply

#8
Okay. Let's trigger some prints that are built into the code for convenience. Can you set the cvar sv_curl_maxspeed to some positive value? You can set it to 999999999, doesn't matter. At least the server log should show us what file names it's trying to cram into that buffer.

Also, just to make sure, you set up sv_curl_defaulturl (not sv_defaulturl as you say in your first post). Can you give me the precise value of that cvar? You can scramble the ip address if you want, but only change the digits.

Aside from that, do you have a curl_urls.txt file in the same directory as your server config? From what you're telling me, you should not have one, which is expected in a simple config like yours.
Reply

#9
I do not have the curl_urls.txt file. i set the maxspeed value you suggested. here is the car value you asked:
sv_curl_defaulturl "http://69.31.30.82/maps/"
i do have the correct sv_curl_defaulturl in the config, it was a typo in the post
Reply

#10
Okay, now can you join the server and look in the server log what appears before the "Could not initiate autodownload due to URL buffer overflow" ? You should see at least one curl --pak blablabla line.
Reply

#11
btw, when i say the server console, i am looking on the real server console, not the console in the game...
This is what i see on the real server console:
WARNING: autogenerated mapinfo file maps/autogenerated/stralegeo1.mapinfo has been loaded; please edit that file and move it to maps/stralegeo1.mapinfo
MapInfo_Type_FromString (probably strength): using deprecated name 'keepaway'. Should use 'ka'.
MapInfo_Type_FromString (probably strength): using deprecated name 'freezetag'. Should use 'ft'.
Authenticated connection to 172.16.2.10:61828 has been established: client is vGvvDoUP/DqkN/SaiNV5FhHYvDtIRa+/ofOXXP5p3Wg=@Xon//Ks, I am pW6BNuY@Xon//Ks
Could not initiate autodownload due to URL buffer overflow
Ti-Grrr connected
Ti-Grrr connected
Ti-Grrr is now spectating
Reply

#12
Yes, sure, that is also what I meant by server console.

It seems that you did not set sv_curl_maxspeed on the server, that log is missing the lines I was mentioning.

EDIT: or you're playing a default map. That could be the reason for it too.
Reply

#13
yes, i added it put have not pushed it to git. the server cfg does have the maxspeed now..
Reply

#14
So, can you post the log of a client joining now? As I said, the log you posted above shows that either it wasn't set at the time, or it was a default map.

EDIT: umm, nevermind, I can't get it to show up either... I'll try some more.
Reply

#15
WARNING: autogenerated mapinfo file maps/autogenerated/stralegeo1.mapinfo has been loaded; please edit that file and move it to maps/stralegeo1.mapinfo
MapInfo_Type_FromString (probably strength): using deprecated name 'keepaway'. Should use 'ka'.
MapInfo_Type_FromString (probably strength): using deprecated name 'freezetag'. Should use 'ft'.
Authenticated connection to 172.16.2.10:51472 has been established: client is vGvvDoUP/DqkN/SaiNV5FhHYvDtIRa+/ofOXXP5p3Wg=@Xon//Ks, I am pW6BNuY@Xon//Ks
Could not initiate autodownload due to URL buffer overflow
Client "unconnected" dropped
Authenticated connection to 172.16.2.10:51472 has been established: client is vGvvDoUP/DqkN/SaiNV5FhHYvDtIRa+/ofOXXP5p3Wg=@Xon//Ks, I am pW6BNuY@Xon//Ks
Could not initiate autodownload due to URL buffer overflow
Ti-Grrr connected
Ti-Grrr connected
Ti-Grrr is now spectating
Receiving player stats failed: -404
Client "Ti-Grrr" dropped
Ti-Grrr disconnected
Reply

#16
Okay, I'm stupid at reading C code, this *wasn't* a debug print. You can remove the maxspeed line from your config and set it back to 0 in your console, that was useless.

I still don't know what causes the trouble. Does the error show up when you try to run a default map?

EDIT: Maybe we should talk on IRC. Join #xonotic on irc.quakenet.org (you can use https://webchat.quakenet.org for that if you're not familiar with irc).
Reply

#17
it appears to give et same message, but it still loads the map i assume because it is part of the game.
Reply

#18
Okay, join irc please.
Reply

#19
It is resolved by deleting all the zz*.pk3 files from server. Thanks!
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Custom Server Downloads Castor 4 1,559 05-24-2018, 07:10 PM
Last Post: Castor
  [SOLVED] Trouble with launch Xonotic on Mac OS X kanatov 6 7,421 10-03-2015, 10:49 AM
Last Post: SomeGuy
  [SOLVED] Trouble Dice 15 9,359 08-10-2013, 07:20 AM
Last Post: tZork
  [SOLVED] [SOLVED]Compiling trouble on Ubuntu Sir Emeth Mimetes 6 21,468 11-25-2010, 06:40 AM
Last Post: Sir Emeth Mimetes

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-