Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[BUG] SDL version not loading, glx version buggy rendering

#1
I have tried to run Xonotic's latest autobuild on my notebook, which has the following CPU with integrated graphics: Intel® Core™ i5-5200U CPU @ 2.20GHz

I'm running on Arch Linux and when I start the sdl startup script (xonotic-linux-sdl.sh) the game loads into a black screen with my mouse on it. I don't see any suspicious errors in the startup log of the console. I can quit it by switching to console and doing CTL-C. 

When running the glx version, the game does run but I get very choppy input and what's even worse players do not get rendered most of the time. I see only the name tag floating about for most of it. And, strangely, Mortar weapon does not get rendered at all. Vortex, Electro, MG, Crylink and Devastator do get rendered, though. I think Hagar as well.

Any ideas? I am working with a clean install, updated to today's autobuild and a brand new autogenerated .xonotic folder. I do not have the option to try official 0.8.2 release right now (mobile bandwidth sucks), but I can do so if that helps.
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply

#2
There is indeed some issues with autobuild on Linux right now (in fullscreen mode).

Relevant bug report: https://gitlab.com/xonotic/xonotic/issues/208

I didn't try to play with the GLX executable though, I was unaware it had issues as well (the choppy input may be caused by the compositor still running, since the GLX executable doesn't bypass it).
Reply

#3
Thank you, I reverted back to release version and voilà, sdl started nicely. However, the player model (mega erebus) often and the mortar (pickup and in hand model) always don't get rendered. I only see a very small semitransparent structure of the whole handheld model of mortar when I hold it. What could cause this?
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply

#4
Are you using an Intel iGPU? What you describe sounds like https://forums.xonotic.org/showthread.php?tid=7366
It seems that this is a problem caused by the GPU driver. However, that problem does not happen if you set "r_glsl_skeletal" to "1"
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Input layout problem in Xonotic-SDL FinBiteLeaf 4 400 03-19-2024, 05:24 AM
Last Post: FinBiteLeaf
  [NEED HELP] NO Sound in Xonotic-0.86-GLX FinBiteLeaf 3 413 03-18-2024, 07:49 PM
Last Post: bones_was_here
  [BUG] A font-rendering performance problem (of upstream DarkPlaces) NaitLee 11 3,151 08-20-2022, 01:23 AM
Last Post: NaitLee
  [NEED HELP] My mouse binds do not work in GLX? FAF 5 1,774 07-29-2022, 08:39 AM
Last Post: FAF
Question [NEED HELP] How to use textures for radiant(win version)? (solved) Kotangens 4 3,065 08-12-2020, 01:33 AM
Last Post: Kotangens
  [SOLVED] No stats for the player Ubuntu 19.04 - just don't use the flathub version Fiorentino 2 3,145 04-20-2020, 07:42 AM
Last Post: Fiorentino
  [NEED HELP] Keybindings not recognized when using the SDL launcher naw 1 1,989 09-02-2019, 05:38 AM
Last Post: naw
  [SOLVED] Weird key hold issue with official version Bloodthorn 9 5,123 05-21-2018, 07:56 AM
Last Post: Bloodthorn
  [NEED HELP] Netradiant Xonotic support version BuddyFriendGuy 0 2,720 04-27-2016, 04:36 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Game crashes while loading - could not load texture "overkillbullet" |OSiRiS| 5 5,517 10-17-2015, 03:44 PM
Last Post: BuddyFriendGuy

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-