Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[BUG] some textures won't load with git builds

#1
we have an issue showing up with git builds, even with nexcompat enabled: some custom maps won't load some textures. curiously, it's mostly quake banners & annoying animated pads underneath weapon spawns. for example, at qzdm7_q3, we get a message:

Code:
MQC Build information: xonotic-v0.8.2-2574-g2f86afcef
Switching to map qzdm7_q3
"maxplayers" set to "16"
loadimagepixelsrgba: corrupt or invalid alpha image textures/sfx/portal_sfx_alpha
maps/qzdm7_q3.bsp: could not load texture "$lightmap" (frame 0) for layer 1 of shader "textures/ad_content/2x1"
maps/qzdm7_q3.bsp: could not load texture "$lightmap" (frame 0) for layer 1 of shader "textures/ad_content/1x1

this issue does not exist with official stable binary build (linux).
Reply

#2
FSMP♩♪♫ мµѕιcgoαт[91] ♫♪♩says you people have got to know what this is all about. bug or not bug, can we please just get some info on this? we tested with (linux x64) git build and autobuild justa a few days ago, and still some banners on some legacy (usually quake) maps are showing checkers. stable 0.8.2 shows banners ok. we really want to understand how we can fix that server-side. these are our options, as far as we can tell, so what do you think is the best way forward, or are we missing anything?

1. do nothing and wait till next xonotic release, because this is a known regression which will be fixed at some point
2. do some magic in configs or data/ dir to replace or disable the checkers somehow
3. fire up netradiant and replace the non-showing textures for good

please help  Smile  we can't sleep anymore, that's how much these checkers are bothering us.
Reply

#3
Guys I have a fix,
sk.void told me about it. So heres what you do:
1. use the terminal to go to the xonotic folder (for me it was msys: cd xonotic)
2. type in: 
Code:
touch data/xonotic-nexcompat.pk3dir.yes

3. then type:
Code:
./all update -l best

4. then run: 
Code:
./all compile -r

you should be good the textures should be back to normal
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] Xonotic won't launch on Win10 noChance79 7 6,496 06-23-2023, 09:49 AM
Last Post: Cofein
  [NEED HELP] Menu Won't Load, Game Crashes EdwardHamHam 1 3,031 07-21-2022, 01:44 AM
Last Post: BuddyFriendGuy
  [NEED HELP] Load my cfg file Rage_ATWM 1 1,209 05-12-2021, 01:01 PM
Last Post: Rage_ATWM
Question [NEED HELP] How to use textures for radiant(win version)? (solved) Kotangens 4 3,121 08-12-2020, 01:33 AM
Last Post: Kotangens
  [SOLVED] Textures don't load at other side of warpzone bananovenc 6 3,171 06-11-2020, 12:56 PM
Last Post: bananovenc
  [NEED HELP] cl_gunalign doesn't seem to work on some servers/maps Aguaumreal 2 2,660 09-10-2019, 03:42 AM
Last Post: Aguaumreal
  [SOLVED] Menu fails to load after recent update Bloodthorn 2 2,901 09-25-2018, 08:11 AM
Last Post: Bloodthorn
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 2,914 07-25-2018, 07:20 AM
Last Post: Bloodthorn
  [NEEDS INFO] Game Crash On Load Castor 0 2,229 05-31-2018, 09:06 AM
Last Post: Castor
  [SOLVED] Xonotic load downloaded maps Bla1 3 5,035 10-01-2017, 06:11 PM
Last Post: Mirio

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-