Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Game Crash On Load

#1
Hi. Sorry if this is a repeat question. 

I've recently started delving into 3D modelling for games. Simple stuff, nothing complex and certainly no excessive poly-counts. I've recently somewhat completed a sort-of simplistic model that I wanted to try getting into Xonotic. I took a long, hard look at the existing models and a couple of models acquired from various mod's that I've picked up from servers. I've done a lot of spying as well through the main Xonotic data archive to gauge what folders should appear where so the game knows what I'm talking about when I select a new character in it.

I've textured my character (pretty sure of it - it certainly shows in Blender as textured, anyway) - again, nothing complex or too large (1024x1024px). The mod' when exported as an IQM hits about 600KB when archived. I double-checked that the list of animations were added just before the export. I used the animations from the ignis-all.blend by just erasing the original model and adding in my one to weightpaint and such...

I've set the folder structure up properly as far as I can tell. I've copied and appropriately-renamed all a set of files concerning the models that I was using for a different character, the model for which is just a copy/paste and renamed Erebus.iqm, as a placeholder. Basically, this new model appears in-game as a separate character, but it should otherwise use the same sound assets.

It does indeed appear in-game as a selectable character, but when I attempt to load up a map to check out how good or bad the actual model when generated is, the game crashes to desktop. No errors, no forewarning. As soon as the loading bar gets to the last file before loading my character, it pauses for a few seconds and then crashes.

I don't suppose anyone knows offhand what would be causing this? Before I knew anything about texturing, I added a Halo Spartan model in-game as  a separate character. It loaded, but was totally invisible (although the rig seemed to be there, as the weapons looked animated as per usual), hence me going away again to stare at a few videos about texturing.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 168 07-25-2018, 07:20 AM
Last Post: Bloodthorn
Exclamation [SOLVED] macOS Sierra: -basedir /path/to/game iqxonotic 7 5,712 04-26-2018, 08:00 AM
Last Post: marataziat
  [SOLVED] Xonotic load downloaded maps Bla1 3 1,259 10-01-2017, 06:11 PM
Last Post: Mirio
Photo [NEED HELP] When in game, the guns keep firing, sometimes doesn't fire when pointed at a target. U1Y5Y5 3 694 09-12-2017, 01:28 PM
Last Post: SpiKe
  [SOLVED] NetRadiant crash "Got to split the buffer" PinkRobot 7 2,003 08-27-2016, 06:16 AM
Last Post: PinkRobot
  [NEEDS INFO] -basedir /path/to/game itsMe 2 1,410 08-17-2016, 09:55 PM
Last Post: BuddyFriendGuy
  [NEED HELP] game modes/mods/types clarification BuddyFriendGuy 13 3,640 06-12-2016, 12:18 AM
Last Post: BuddyFriendGuy
  [FIXED] How do I pause game while having the console open? Beagle 8 2,491 05-14-2016, 02:35 PM
Last Post: Beagle
  [SOLVED] -basedir /path/to/game? :P 7 3,724 11-28-2015, 06:57 AM
Last Post: PinkRobot
  [NEEDS INFO] Game crashes while loading - could not load texture "overkillbullet" |OSiRiS| 5 2,488 10-17-2015, 03:44 PM
Last Post: BuddyFriendGuy

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-