Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] NetRadiant crash "Got to split the buffer"

When I use any of the lava textures in liquids/liquids_lava my build process crashes on the -bsp stage with some gibberish and ending in multiple lines reading Got to split the buffer.

Online I am being told on several pages that:

This is memory related. Chances are your map is far too complex or there are brushes in your map that have issues. Try running Bobtoolz brush cleanup on your map. Also check your VIS data size. If it's high try utilizing detail brushes.

It does not seem to have to do with geometry though, it even happens with a simple box with any of these textures on it. (Using a different texture on it works fine.)

I am on 64bit Windows 7 and am using the NetRadiant shipped with Xonotic's latest mappingsupport file on the autobuild downloadsite.

Anyone a clue as to what I could try?

OK nevermind, I fixed it by replacing my NetRadiant with the latest one on Ingar's website.

That one looks a lot prettier too, with native Windows menu's and not disabling all Windows window effects. And my mouse is not all over the place either. Yay!

Is there a reason why the NetRadiant shipped with the latest mappingsupport file is still from 2012? Or am I the only one using it on Windows? Big Grin
"Yes, there was a spambot some time ago on these forums." - aa

Strange, I couldn't reproduce this issue. I am on a different platform though (Debian Stretch 64bit).

Two things:
  • Could you post a map that crashes for you when you try to compile it?
  • Is there any way for you to try different versions of NetRadiant (and thus Q3Map2)?

Thanks for taking a look at it! This is my very simple test map.

I don't really know how to use another NetRadiant than the one that came with the MappingSupport file or the one I found at Ingar's. But at any rate, whatever issue this was, it seems to be fixed in the new version I downloaded.

Another problem I am having in both the earlier version and this newer version is that whenever I start to do real work after a while small white or black blocks appear on the 2D and 3D views and my mouse goes crazy. The mouse input becomes far too sensitive and the 3D view will sometimes even start rotating like a maniac.

I guess all of this is my punishment for not having switched back to Linux already :p
"Yes, there was a spambot some time ago on these forums." - aa

You can check out of Linux any time you like, but you may never leave...
[Image: 0_e8735_c58a251e_orig]

Haha Big Grin well, I'm glad you fixed your issue with a different version. The general weirdness of NetRadiant on Windows may be caused by multiple things: GTK, which just doesn't work that well on Windows (on Linux it does though); the very old code basis which at some parts exist over a decade and got patched at so many points with so many different things that I can't even remember how I came up with a sentence with so many "so many"s... wtf did I just wrote? Anyway... NetRadiant is simply weird under Windows... come back to Linux already! Big Grin

So it seems NetRadiant for Windows is in a pretty bad state. I installed it on a second Windows laptop. This time it's Windows 10. The mouse acts better this time and does not warp me all over the place. However, the drawing artifacts are still there as soon as you touch the Ctrl or Shift keys. And what's worse is that the texture explorer is only usable once. When you open it a second time, no textures appear at all.

Is anyone here succesfully using NetRadiant on Windows right now?
"Yes, there was a spambot some time ago on these forums." - aa

@PinkRobot: I'm a Linux user, but I also use Windows sometimes.
I ended up using this custom NetRadiant build from Garux:
This build fixes a bunch of bugs.

However, I had to copy "netradiant\\" and "netradiant\games\" from the official NetRadiant build, because these folders & files are missing from Garux's build.

Thank you Spike, this one seems to work a lot better! I still have mouse issues on the first laptop but it seems to work without problems on the Windows 10 one so it seems at long last I can map again.
"Yes, there was a spambot some time ago on these forums." - aa

Possibly Related Threads…
Thread Author Replies Views Last Post
Question [NEEDS INFO] how to make the model smoother? (netradiant) Beylet 2 1,255 06-20-2022, 11:50 PM
Last Post: Beylet
Question [NEED HELP] Certain maps crash my game :( flexo 6 3,901 01-17-2022, 08:55 PM
Last Post: flexo
  [NEED HELP] Netradiant, xonotic-mapping-support and maps dir? Gwlanbzh 1 1,501 02-02-2021, 06:57 PM
Last Post: AriosJentu
Heart [SOLVED] BUG IN NETRADIANT Kotangens 5 2,659 12-06-2020, 08:53 AM
Last Post: Julius
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 3,371 09-23-2020, 12:05 AM
Last Post: fabzor3
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 3,719 01-03-2020, 11:31 AM
Last Post: SpiKe
  [SOLVED] how do i set up netradiant bananovenc 2 3,278 12-27-2019, 02:04 PM
Last Post: bananovenc
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 7 4,652 12-25-2019, 03:34 PM
Last Post: illwieckz
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 1,634 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 1,686 04-24-2019, 10:41 PM
Last Post: Space Ace

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-