Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] How To Disable Travelling "Update Now" Notification

#1
how the heck can I disable the travelling "update now" notification from older versions?
thanks in advance and mark thread as solved upon your answer, that I know you will have even though I have repeatedly scoured the ether
gt
I'm sure many would like to know this, or maybe I'm missing something.
Reply

#2
Download information:

Download via HTTP
Download via torrent
MD5: 324aee42e9f3e5e254adc8f3f7d4cb00
Package size: 946M

Already have Xonotic on your machine? There’s no need to download the game again to get into the action. Use the following steps to upgrade your client to the 0.8.2 release:
  1. Navigate to your Xonotic installation folder
  2. Navigate to the misc/tools/rsync-updater folder
  3. Execute the update-to-release.sh (for Linux or Mac) or update-to-release.bat (for Windows) and wait for it to complete
  4. Profit. You’re done!
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8

Reply

#3
I think this guy doesn't want to install new version.
Reply

#4
(04-28-2017, 01:20 AM)Anter Soul Wrote:
Unless you have specific motives, you should get the latest release.
That is cos, it is the result of the evolution; stable, bug-less, and closest to creator's perspective.

A method:

       - Chose git branch which match your Xonotic version (Didn't tried with source dir at the official copy yet).
       - Modify "preMenuDraw()" function at ".../qcsrc/menu/xonotic/util.qc".
       - Make in qcsrc dir (gmqcc needed).

If you can sort all errors and specific needs (I had to mod "tools/qcc.sh" like this, removing all '^# ' for QuakeC compiler to work), you get progs ("../menu.dat" in this case) that can be zipped (check "../Makefile" and "info zip" command for usage) into your Xonotic version pk3.
Then also gain possibility to mod any other stuff in the source you like.
Reply

#5
thanks folks, but "this guy" (ha) has updated to new version, from the working ver8 with stupid "update now" message to ver8.2 and 8.2 is way too buggy for me, even after editing several pertinant script files.....stutters and skips intervals at all video presets, but previous versions, all of them, work well.....most of them working great even on high video preset - but that stupid "update now" is all over them
please include simple step by step on how to disable the stupid "update now" - i know there is a way simple way
remember, marketing and legal departments are not supposed to be making the big decisions folks
Reply

#6
(04-28-2017, 08:18 PM)Anter Soul Wrote: note: later i edit this to look better, correct the errors ad give info about the function. For now check what i left at the previous message. Hope this helps.

.it isnt so hard and tedious
in my knowledge there is no other way (you where thinking about change a cvar value and thats it)

you give no technical or bug info.

im doing this from osx with xcode and command line tools. In your case may be difrent.

but , once you have compile your first binary from a source code, you are ready to make it throw easily.

the makefiles involved at progs making have all the needed info for any supported plataform, but it may be necesarily to you navigate into certain scripts to find the solution for your specific ishu (the comunity cant prevent all cases)

so the step by step in my case its like this:
 1- Be sure that compiling requieriments are fullfiled.
To compile gmqcc, at terminal go gmqcc dir via cd command example: cd /Users/yourusr/games/source/gmqcc
Once there, the simplest way to compile its to do: "./configure"  this prepares all info the program its gonna need to adapt to your system. Somtimes its needed to install previous programs or packages, so if thats the case just google them and repeate this three steps.
"make" this will make the binaries from the source code files. It is necesarilt to run it like root; "sudo make". In some cases you have to check the file called "Makefile" (which is the file that "make" command acces for info to know what to do), to find specific otions or to solve some bugs.
"make install" this is an option explicity declared at "Makefile" wich install the recent compiled binaries to a directory where it can be called by the terminal as commands. This dir is the PATH variable. This command have to be runed with root permisions.

2-Once you installed succesfully gmqcc, you have to find the file "util.qc" at qcsrc dir of the source you downloaded, and open it with a text editor, it can be use xcode or nano command.
The function that manage the notification its called preMenuDraw() then you change the content of it like this to disable it. Even you can print other mesage or change movement or color of the notification.

3- With your modified file done, yo have now to make the menu programs.

"cd /path/to/source/qcsrc
sudo make"
This commands its making the progs from the modified source.
At this moment i had an ishu: "junk after pragma" or something like at making, so i solved that mod the qcc.sh file to delete all lines that where making touble before qcc function starts. Those where all '^# '.

4- If this result for you, then you have four progs: "csprogs.dat", "menu.dat", "server.dat" and "csprogs-version-etc.pk3". All ".dat" are at the uper directory "xonotic-data.pk3dir", which you can acces with cd .. or at finder or folders, and the ".pk3" are at qcsrc dir.

5- At your data directory at xonotic 0.8.0 you find the xonotic-data.pk3 file wich is a kind of zip file.
Now insert the mod progs to make it work;
convert xonotic-data.pk3 to  xonotic-data.zip, then extract the conten to a folder named xonotic-data.pk3dir. Then you can acces for search the files to find the the original progs. Once findem you move then to backup directory you like, and substitute them with the progs of youre own mod.
The game read the directory even if are not compressed but if you like to have it like pk3:
"cd xonotic-data.pk3dir
zip -9 -r ../xonotic-data.pk3 *" this process can be found at xonitic-data.pk3dir/Makefile.
note: later i edit this to look better, correct the errors ad give info about the function. For now check what i left at the previous message. Hope this help
s.
Why dont you make a bug report about the problem you have with 0.8.2 release?
Reply

#7
OK, I meant this as a quick little tutorial for EVERYBODY on how to undo something stupid that shouldn't have been done in the first place.  And now it has turned into this giant mess of doubletalk that nobody will even bother to try to interpert in the first place.  Is this what you want?  To FORCE everybody into the latest version even though the newest version in this case SUCKS?
Just identify the script file that performs this stupid "update now" travelling message and share with US the code change to eliminate this stupid "update now" travelling message.  That is all WE want.
Supply the simple I am sure only two step answer and mark this threat (that has turned into a real cryptic mess already) CLOSED.
Thank you.
Reply

#8
Ay. M80. Be polite and respectful. I agree, the bouncing banner is cancer and there's no reason why it shouldn't be easy to remove (a simple [x] button would do). But your terrible attitude isn't gonna make anyone help you.
Also, like Anter Soul said, it would be great if you could file a bug report, as others might also be having similar issues with the new update as you are.
Reply

#9
(04-28-2017, 11:18 PM)Cinnamon Juice Wrote: Ay. M80. Be polite and respectful. I agree, the bouncing banner is cancer and there's no reason why it shouldn't be easy to remove (a simple [x] button would do). But your terrible attitude isn't gonna make anyone help you.
Also, like Anter Soul said, it would be great if you could file a bug report, as others might also be having similar issues with the new update as you are.

mark this hopeless thread closed
game on while the world burns
Reply

#10
After all these years, nobody has reported an issue on the tracker about the update notification, so it hasn't been given priority...

As for your performance issues; there's a couple of console settings that may boost FPS a little:
crosshair_hittest 0
hud_shownames 0

You can access the console by pressing ~ (tilde) or holding SHIFT and pressing ESCAPE.


We can't recommend using an old release, as you will experience quite a few issues on servers (namely black maps, missing graphical features, and in more extreme cases, simply not being able to join at all).
0.8.2 is known to be a bit more resource intensive than previous releases due to the new high quality weapon models, a solution is being prepared that will lighten the load from them.
[Image: 230.png]
Reply

#11
(04-29-2017, 12:29 AM)Mario Wrote: After all these years, nobody has reported an issue on the tracker about the update notification, so it hasn't been given priority...

As for your performance issues; there's a couple of console settings that may boost FPS a little:
crosshair_hittest 0
hud_shownames 0

You can access the console by pressing ~ (tilde) or holding SHIFT and pressing ESCAPE.


We can't recommend using an old release, as you will experience quite a few issues on servers (namely black maps, missing graphical features, and in more extreme cases, simply not being able to join at all).
0.8.2 is known to be a bit more resource intensive than previous releases due to the new high quality weapon models, a solution is being prepared that will lighten the load from them.
very pro response, however not all players even use the server playing people in the ether
sure would like to have had my very simple question answered, but what you have provided will permit me to leave this forum without a bitter taste in my mouth
THIS THREAD IS CLOSED, and would prefer deleted
Reply

#12
(04-29-2017, 01:00 AM)garyt53 Wrote:
(04-29-2017, 12:29 AM)Mario Wrote: After all these years, nobody has reported an issue on the tracker about the update notification, so it hasn't been given priority...

As for your performance issues; there's a couple of console settings that may boost FPS a little:
crosshair_hittest 0
hud_shownames 0

You can access the console by pressing ~ (tilde) or holding SHIFT and pressing ESCAPE.


We can't recommend using an old release, as you will experience quite a few issues on servers (namely black maps, missing graphical features, and in more extreme cases, simply not being able to join at all).
0.8.2 is known to be a bit more resource intensive than previous releases due to the new high quality weapon models, a solution is being prepared that will lighten the load from them.
very pro response, however not all players even use the server playing people in the ether
sure would like to have had my very simple question answered, but what you have provided will permit me to leave this forum without a bitter taste in my mouth
THIS THREAD IS CLOSED, and would prefer deleted

Settings > Misc > Advanced settings...
In "Cvar filter" (search bar at the top) enter "menu_updatecheck"
then select the entry "menu_updatecheck" and set the "Value" field to "0" (zero)
click ok, maybe restart the game, done !
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Menu fails to load after recent update Bloodthorn 2 415 09-25-2018, 08:11 AM
Last Post: Bloodthorn
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 523 07-25-2018, 07:20 AM
Last Post: Bloodthorn
  [SOLVED] libc++ update Bloodthorn 4 569 06-22-2018, 06:48 AM
Last Post: Bloodthorn
  [SOLVED] Difference of the 2 update scripts? dreamteam 2 1,861 11-30-2015, 04:35 PM
Last Post: dreamteam
  [SOLVED] Can I disable "while in the midair press jump and jetpack is activated" zwz 2 2,176 04-21-2015, 02:06 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Tearing issues since last update Halogene 0 1,909 01-16-2014, 05:28 AM
Last Post: Halogene
  [SOLVED] Quick Question about the update tool satuim 14 7,051 06-28-2013, 05:17 AM
Last Post: satuim
  [SOLVED] update autobuild 11. jan disabled playerstats -maniac|Su- 11 9,211 02-20-2013, 03:57 PM
Last Post: Mr. Bougo
  [SOLVED] Error compiling DP after update GIT on linux Leeloo 2 3,565 06-01-2011, 08:26 PM
Last Post: Leeloo
  [NEEDS INFO] x11 update broke netradiant theShadow 3 3,359 04-14-2011, 01:10 PM
Last Post: theShadow

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-