Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Trouble unzipping cygiconv-2.dll on Windows 7 (0.8.5)

Trying to update from Xonotic 0.8.2 to 0.8.5 on my Windows 7 desktop. I've downloaded, but when I try to unzip it, file cygiconv-2.dll fails with error code 0x80004005. 

All other files appear to be unzipped normally, but if I try running update-to-release.bat, rsync.exe fails with system error "cygiconv-2.dll missing".

I'm thinking of trying to download Cygwin and copy the DLL from that package. Any other ideas?

I tried copying the DLL from Cygwin and running update-to-release.bat generates a new error: rsync.exe application error "Cannot correctly run application (0xc000007b)". Any idea?

Replacing rsync.exe that came zipped with 0.8.5 with the latest rsync.exe version from MinGW allowed update-to-release.bat to run to normal completiong.

I get a similar error (transcribed below) while unzipping the full file in Windows 10, also complaining about cygiconv-2.dll.  I also tried using a Linux computer (namely, LMDE=Linux Mint Debian Edition 5), and it successfully unzipped all files.  Using LMDE's own zip facility, I unzipped and then re-zipped the contents of  My own zip file unzips in Windows without any trouble, including cygiconv-2.dll.  I think something went wrong in the process of zipping cygiconv-2.dll into the provided on this website.

Quote:1 Interrupted Action
An unexpected error is keeping you from copying the fie.  if you continue
to receive this error, you can use the error code to search for help with this
Error:  0x80004005:  Unspecified error
  Type: Application extension
  Date modified:  2022-06-27 8:32 PM
  Size: 0.98 MB
[ ] Do this for all current items
     [ Try Again ] [ Skip ] [ Cancel ]

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Trouble with setting up a non-local private server spaceenfix 3 3,962 03-22-2023, 12:53 AM
Last Post: FAF
  [NEED HELP] Windows 10 -basedir problem BlazedRasta 4 4,592 03-21-2023, 07:34 PM
Last Post: AlexVelasquez
Bug [BUG] strange checker pattern in the middle of explosions on Windows 10 fabzor3 2 2,946 09-23-2020, 08:38 AM
Last Post: fabzor3
  [NEED HELP] video glitches in netradiant on windows 10 fabzor3 2 3,091 05-26-2017, 02:09 AM
Last Post: PinkRobot
  [TUTORIAL] How To Migrate accounts! (Windows) shanajer_ 1 2,294 03-06-2017, 06:09 PM
Last Post: -z-
  [SOLVED] Trouble with launch Xonotic on Mac OS X kanatov 6 11,474 10-03-2015, 10:49 AM
Last Post: SomeGuy
  [SOLVED] Trouble with .8 and map downloads kuedan 18 17,352 02-14-2015, 05:36 PM
Last Post: kuedan
  [NEEDS INFO] Apparently this game hates Xonar cards running under Windows 8 Lee_Stricklin 4 5,890 09-20-2014, 05:33 AM
Last Post: Lee_Stricklin
  [SOLVED] sdl.dll missing wind8.1 maek234 4 6,021 07-05-2014, 04:15 AM
Last Post: Mr. Bougo
  [SOLVED] Locating Config file in windows 8 Racoon 3 5,372 02-09-2014, 11:08 AM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-