Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] netradiant still not working

ok, this is really starting to irritate me, now my net radiant won't build because now it is saying that the bsp doesn't exist when it's supposed to be building it

Are you trying to build NetRadiant from source or compile a map?

* Spaceman can't help with either answer

Yeah, you're not giving us any details. It's kinda hard to help. I have this one program that crashes when I press Cancel, do you think you can help me?

(07-08-2012, 07:16 AM)Mr. Bougo Wrote: I have this one program that crashes when I press Cancel, do you think you can help me?


It's probably similar to this problem?
"Yes, there was a spambot some time ago on these forums." - aa

oh, right of cource

i'm using the compiled version of net radiant, and i've had success with building maps before. whenever i build a map, i try and play test the map and it doesn't load at all, sometimes it just goes back to the main menu, others it gets stuck on the background and i have to hit escape. net radiant doesn't throw up any errors, and the maps show up, but don't work. all the other maps i've made still work, it's just the new maps. would re-installing net radiant help?

oh, also the previous problem has been resolved, and nothing i do helps with the new one

Please, write the error message down so we know what exactly it complains about! (while compiling and while trying to load the map in game)

it says nothing actually, it just shows the backdrop or it doesn't go to the map and refuses to load anything

does anything pop up in xonotic's console? ([shift]+[esc] ... or [~] to get there)

do you have any warpzones (or cameras) in your map?

the only thing that pops up is

"maxplayers" set to "16"
map <levelname> : start a new game (kicks off all players)

that is the most recent kind of error

im gona need more info than that ... show everything in xonotic console from startup to error

all it sais is that it failed to load the default welcome, then it disconnects, then it sais what i stated before

that is all the information i can give, there are no other errors

No crash, nothing? Not even when you launch Xonotic from a command prompt and look in there?

You should package the broken compiled map so others can test it.

here's a video of what happens when i load these maps

i didn't realize how loud the music was untill i watched the video, sorry about that

Stupid question... are you sure you have added at least some info_play_deathmatch entities?

Also, does the console of NetRadiant (while compiling) output any warnings or errors?

(10-22-2012, 01:00 AM)Mr. Bougo Wrote: You should package the broken compiled map so others can test it.

(10-23-2012, 12:43 PM)Mr. Bougo Wrote:
(10-22-2012, 01:00 AM)Mr. Bougo Wrote: You should package the broken compiled map so others can test it.
how exactly do i go about doing that?

Uh, make a pk3 just like you'd do for any other map?

Basically, put inside a zip archive every file that's needed to run the map, in a hierarchy corresponding to Xonotic's. Then give that zip archive a .pk3 extension.

For example, in brokenmap.pk3:
maps/brokenmap.mapinfo (optional, but please at least put the autogenerated one in there if possible, it's located in data/data/maps/autogenerated/ in your personal directory)
but really, only the .bsp is needed in this case (but please add the mapinfo if possible). Just make sure you put it in a "maps" directory in the archive.

wiki to the rescue


this problem is no longer an isue, i had to wipe my hard drive clean and install linux on it, so, problem solved?

well ... thats one way of fixing a lot of things :3

(although you still didn't state if its actually working or not ... some distros ... (like opensuse) dont play nice with radiant)

Possibly Related Threads...
Thread Author Replies Views Last Post
Question [NEEDS INFO] how to make the model smoother? (netradiant) Beylet 2 321 06-20-2022, 11:50 PM
Last Post: Beylet
  [NEED HELP] Netradiant, xonotic-mapping-support and maps dir? Gwlanbzh 1 869 02-02-2021, 06:57 PM
Last Post: AriosJentu
Heart [SOLVED] BUG IN NETRADIANT Kotangens 5 1,463 12-06-2020, 08:53 AM
Last Post: Julius
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 2,337 09-23-2020, 12:05 AM
Last Post: fabzor3
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 2,314 01-03-2020, 11:31 AM
Last Post: SpiKe
  [SOLVED] how do i set up netradiant bananovenc 2 2,257 12-27-2019, 02:04 PM
Last Post: bananovenc
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 7 2,764 12-25-2019, 03:34 PM
Last Post: illwieckz
  [NEED HELP] Spacebar not working on Erbium Deathmatch. Pallama 2 1,721 09-24-2019, 03:44 PM
Last Post: Pallama
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 1,218 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 1,261 04-24-2019, 10:41 PM
Last Post: Space Ace

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-