Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Flickering when Fullscreen - Mac Mini OS X

#1
Hi, I've been playing Xonotic for a few days successfully on a macbook air and PC. However on my mac mini, when I change to full screen and full resolution (1920x1080) it flickers really bad. At the same resolution in windowed mode it doesn't flicker. 1600x900 at full screen is also fine.

The mac mini has a AMD Radeon HD 6630M 256 MB graphics card, and is running OS X Mountain Lion (10.8.2).

Anyone have any ideas what this could be?

Thanks for any help!
Reply

#2
Could you describe the flickering a little more specifically?

This is a shot in the dark, but maybe enable/disable vsync?
Reply

#3
I´m also unsure what you exactly mean by flickering? JayWalker could be right that vsync is your issue.

Maybe it´s your graphics card? It doesn´t seem to have such a good performance when playing with FullHD resolution. It would be useful to know which settings you use in Xonotic.
Reply

#4
Hi, thank you for the response.

I apologize for my vagueness - the flickering is hard to describe. It's not the type of "tearing" you get when vertical sync is disabled, and I also tried without v-sync with no differences. Other graphics settings were adjusted to no avail.

The flickering seems almost like the refresh rate is really low. It's sort of similar to the stuttering you would see when taking a video of a TV screen. I'll see if there's some way I might be able to take a video.

I think the graphics card should be ok, I've played many other games full screen, and additionally Xonotic runs fine at the same resolution but in windowed mode.

Thanks again for any tips!

Update: I took a video, however the flickering is not seen at all, which I think might be due to the half frame rate of the video (30 frames). Definitely reminds me of the old CRTs with a low refresh rate.
Reply

#5
Is there any way with the screen that you're using to get information on the refresh rate? Many monitors have an info screen somewhere in the On Screen Display which gives you resolution and refresh rates. Compare this for full screen and when windowed and see if there is a difference.

You can override the refresh rate (eg. 60Hz) in the console with:
Code:
vid_refreshrate 60
vid_restart
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#6
(11-26-2012, 11:03 AM)edh Wrote: Is there any way with the screen that you're using to get information on the refresh rate? Many monitors have an info screen somewhere in the On Screen Display which gives you resolution and refresh rates. Compare this for full screen and when windowed and see if there is a difference.

You can override the refresh rate (eg. 60Hz) in the console with:
Code:
vid_refreshrate 60
vid_restart

Thank you for the tip - I checked the OSD, and it says that the refresh rate is half when running Xonotic full screen. Another strange thing is that the resolution says 1920x1079 instead of 1080.

I tried overriding the rate in the console but it didn't help. It seems like the setting isn't having an effect.

Thanks again, at least I feel like I'm getting closer!
Reply

#7
(11-26-2012, 11:31 AM)undone Wrote: Thank you for the tip - I checked the OSD, and it says that the refresh rate is half when running Xonotic full screen.

That's wierd as modern screens simply don't use 30Hz, hence what you are seeing. What is the refresh rate reported at for 1600x900? You might be able to find some other number that will be OK. Do you have similar problems with other games?
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#8
(11-26-2012, 06:32 PM)edh Wrote:
(11-26-2012, 11:31 AM)undone Wrote: Thank you for the tip - I checked the OSD, and it says that the refresh rate is half when running Xonotic full screen.

That's wierd as modern screens simply don't use 30Hz, hence what you are seeing. What is the refresh rate reported at for 1600x900? You might be able to find some other number that will be OK. Do you have similar problems with other games?

Yes, it is pretty strange... this is the only game and application that does this (I've played Warsow, Conterstrike, Team Fortres). Using the same monitor on PC works fine too in Xonotic.

The refresh rate at 1600x900 is normal. 1920x1080 is the "native" resolution for my monitor I'm guessing there's some sort of correlations with that.
Reply

#9
OK, perhaps another thing to check. Run the game from the command line and add "-width 1920 -height 1200 -bpp 32 +vid_refreshrate 60" to the command line. This will start the game up and force resolution and 60Hz refresh rate. You can run everything forced in some way from the command line so there will be some way to get this working correctly.
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#10
Fixed!!!

I swapped out the SDL framework in the OS X app package with the latest version (1.2.15).

Release notes are here (although it doesn't mention this problem in particular):

http://www.libsdl.org/release/changes-1.2.html

In order to get this working for anyone else having problems, follow these instructions:
  • Download the "Runtime Library" dmg file for SDL 1.2.15 : here
  • Open the dmg and copy the "SDL.framework" folder
  • Right click your Xonotic.app and select "Show package contents"
  • Browse to /Xonotic.app/Contents/Frameworks/ and rename or remove the "SDL.framework" folder.
  • Paste in the new SDL.framework folder from your download.
  • Start Xonotic.app

Hope this is able to help anyone else out!

I've submitted a formal bug report for this as well:

http://dev.xonotic.org/issues/1350
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Low FPS when using FullScreen mode TheLastCrawler 0 1,400 09-06-2015, 10:02 AM
Last Post: TheLastCrawler
Exclamation [NEEDS INFO] Xonotic can't be played on fullscreen... Knyghtmare 8 5,760 06-21-2013, 09:03 AM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-