Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] bots

#1
Hi all Smile

By playing in single-player , i have noticed that some bots "camp".
They stand ,at bottom of the map. When the game mod is "elimination" ,it is very difficult to find them, and they can stand all the match by killing anyone , standing at the bottom of the map.


Is it normal?(bug???)
Reply

#2
Bots just have limited intellectual capabilities. Since the focus is on online multiplayer gameplay, the development focus is usually elsewhere :o)
[Image: 249.png] Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out my Newbie Corner!
<ZeRoQL> i think i got 1 proper quad and that cunt halogen fuck me over with a laser
Reply

#3
OK i understand.I'm a bit disappointed because it is right that the game is essentialy multiplayer , but I like to train with bots.(and when my connection don't work ,it is nice to have a singleplayer game.

I opened that topic because I have noticed that in another free games , bots have better abilities (especially in "red eclipse")
Reply

#4
I you have any knowledge in coding you may help. It seems to happen only in elimination (or at least in dm they move) and the code is located here: http://dev.xonotic.org/projects/xonotic/...igation.qc
or maybe here: http://dev.xonotic.org/projects/xonotic/...ypoints.qc

Even if you don't have, the more clues you give to enhance it (when it happens, where, which gametype, map and so on), the easier it will be to fix things.
Reply

#5
Non-official maps usually do not have bot waypoints, and there is no mode called elimination AFAIK.
Reply

#6
(05-08-2014, 07:28 AM)frostwyrm333 Wrote: Non-official maps usually do not have bot waypoints, and there is no mode called elimination AFAIK.

it is possible , but you have understand what i am speaking about.
Reply

#7
Or you have to understand what frostwyrm333 said. So to my understanding bots work by walking to waypoints, collecting items and when they meet you they attack. Non-official maps don't have these making them quite un-playable, some maps they just stand still at their spawns. If it is just some random map you tried on then it is probably caused by that.
Reply

#8
Yes , it is right that it was a random match.

(05-08-2014, 03:42 AM)Karamel Wrote: I you have any knowledge in coding you may help. It seems to happen only in elimination (or at least in dm they move) and the code is located here: http://dev.xonotic.org/projects/xonotic/...igation.qc
or maybe here: http://dev.xonotic.org/projects/xonotic/...ypoints.qc

Even if you don't have, the more clues you give to enhance it (when it happens, where, which gametype, map and so on), the easier it will be to fix things.


Sorry , i don't have have and don't remeber the exact map ,mod..
Reply

#9
After playing , i have noticed a bug in the level 6 : Key Hunt :Runnig man.
Try it : the bots don't move or run into the walls.
Reply

#10
Runningman CTF (with red and blue zones) don't have waypoints on 0.7 (Silent Siege has some bugs too). Those are already fixed and waiting for inclusion by the time I'm writing this.

If you want to fix on your machine it until then unzip the attached files in data/maps/

There are some issues on Oilrig with water which I don't know how to fix. If you find any other bot issue feel free to report it Smile

(edit: it doesn't work for updating the single player mode, but it will work if you create a multiplayer game)


Attached Files
.zip   runningmanctf_waypoints.zip (Size: 3.23 KB / Downloads: 2)
.zip   silentsiege_waypoints.zip (Size: 2.73 KB / Downloads: 1)
Reply

#11
thank you , I will unzip it . Smile
Reply

#12
OK I can give an example:

In map "Solarium", bot always "camp" in the underground water tunnel. I think it's because it can not figure out the next waypoint.
Reply

#13
Yes. Waypoints usually have a defined height from the ground where they will work. In water everything is screwed up. Bots are lost there.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Add Bots using Console in Xonotic OpenSourceGames 1 2,288 08-09-2019, 10:16 AM
Last Post: martin-t
  [SOLVED] Adding bots with ai to custom maps in single player axe 4 6,384 04-04-2013, 05:34 PM
Last Post: axe
  [NEEDS INFO] Bots get stuck or don't move at all rafallus 7 5,244 01-22-2012, 04:40 AM
Last Post: Maddin
  [SOLVED] "Instant action! (random map with bots)" button does not work. TheLastProject 2 3,179 03-13-2011, 06:58 AM
Last Post: TheLastProject

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-