Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[BUG] INFO_ITEM_WEAPON_UNAVAILABLE Crash

#1
Hi guys

I really can't find any help to solve my problem.
sometimes when i try to join some servers right when Xonotic starts to load after downloading map it crashes and goes to the homepage.
Starting it from the terminal (after all the right log) i got this message every time
Code:
Beginning notification initialization on CSQC program...
TRAILING NEW LINE AT END OF NOTIFICATION: net_type = MSG_INFO, net_name = INFO_ITEM_WEAPON_UNAVAILABLE, string = NORMAL.
TRAILING NEW LINE AT END OF NOTIFICATION: net_type = MSG_CENTER, net_name = CENTER_ITEM_WEAPON_UNAVAILABLE, string = NORMAL.
======client ERROR in RegisterNotifications_Done:
Notification initialization failed! Read above and fix the errors!


client EDICT 0:
mins           '-1736.79993 -1747.20007 -665.599976'
maxs           '915.199951 1206.3999 832'
message        
Host_Error: client: Program error in function RegisterNotifications_Done:
Notification initialization failed! Read above and fix the errors!

Tip: read above for entity information

QuakeC crash report for client:
s17788: IFNOT      notif_global_error (=1), statement 17796
s17789: IFNOT      autocvar_notification_errors_are_fatal (=1), statement 17793
s17790: STORE_S    GLOBAL10773, GLOBAL4
s17791: CALL1      error (=error())
../common/notifications.qh : RegisterNotifications_Done : statement 3
../common/notifications.qh : RegisterNotifications : statement 683
     Main.qc : CSQC_Init : statement 67

I'm in debian wheezy. I just say i have no problem in starting the game and playing even in multiplayer.
It just crashes on some servers and gives me this message.

Thanks for any help
Reply

#2
(01-02-2015, 03:02 PM)coppelius Wrote: Hi guys

I really can't find any help to solve my problem.
sometimes when i try to join some servers right when Xonotic starts to load after downloading map it crashes and goes to the homepage.
Starting it from the terminal (after all the right log) i got this message every time
Code:
Beginning notification initialization on CSQC program...
TRAILING NEW LINE AT END OF NOTIFICATION: net_type = MSG_INFO, net_name = INFO_ITEM_WEAPON_UNAVAILABLE, string = NORMAL.
TRAILING NEW LINE AT END OF NOTIFICATION: net_type = MSG_CENTER, net_name = CENTER_ITEM_WEAPON_UNAVAILABLE, string = NORMAL.
======client ERROR in RegisterNotifications_Done:
Notification initialization failed! Read above and fix the errors!


client EDICT 0:
mins           '-1736.79993 -1747.20007 -665.599976'
maxs           '915.199951 1206.3999 832'
message        
Host_Error: client: Program error in function RegisterNotifications_Done:
Notification initialization failed! Read above and fix the errors!

Tip: read above for entity information

QuakeC crash report for client:
s17788: IFNOT      notif_global_error (=1), statement 17796
s17789: IFNOT      autocvar_notification_errors_are_fatal (=1), statement 17793
s17790: STORE_S    GLOBAL10773, GLOBAL4
s17791: CALL1      error (=error())
../common/notifications.qh : RegisterNotifications_Done : statement 3
../common/notifications.qh : RegisterNotifications : statement 683
     Main.qc : CSQC_Init : statement 67

I'm in debian wheezy. I just say i have no problem in starting the game and playing even in multiplayer.
It just crashes on some servers and gives me this message.

Thanks for any help

Its been like that for a long time. I think Mario said its an issue with the dark places engine and not Xon.
[MoFo] Servers - North America - Hosted in Kansas USA - Admin DeadDred [MoFo]
Reply

#3
okay for me then, just wanted to know. Thank you end user
Reply

#4
The problem is translations and 0.7 compatibility with latest Git servers. Please try setting your language to something else (English is known to work).
[Image: 230.png]
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEEDS INFO] Game Crash On Load Castor 0 864 05-31-2018, 09:06 AM
Last Post: Castor
  [SOLVED] NetRadiant crash "Got to split the buffer" PinkRobot 7 2,645 08-27-2016, 06:16 AM
Last Post: PinkRobot
  [SOLVED] Crash Upon Starting Second Level After Quitting First ehrenbrav 2 2,099 06-10-2015, 09:41 AM
Last Post: ehrenbrav
  [SOLVED] Video menu causes the game to crash Divergence 8 5,621 11-02-2013, 04:55 PM
Last Post: edh
  [NEEDS INFO] Server crash report Vargos 21 10,087 04-17-2013, 01:21 PM
Last Post: Mr. Bougo
  [SOLVED] Black screen and crash at launch kiro 3 3,209 08-11-2012, 04:59 PM
Last Post: Mr. Bougo
Wink [NEEDS INFO] Internet crash 5 - 10 minutes into match Serok 4 3,589 07-16-2012, 10:47 AM
Last Post: Serok
  [SOLVED] crash at launch ApexjE 14 8,135 06-16-2012, 08:58 AM
Last Post: ApexjE
  [BUG] Steam overlay will intermittently crash Xonotic DW_ 4 3,845 06-15-2012, 06:35 AM
Last Post: DW_
  [SOLVED] DSL Crash while playing Xonotic Psygnosis 16 10,376 04-16-2012, 07:48 PM
Last Post: Psygnosis

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-