Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Platform testing needed - Windows and OSX only

#1
Information 
In order to prepare ourselves for the next release of Xonotic we need to confirm that the game works correctly on the following platforms and architectures:

* OSX Lion
* Windows XP -32 bits only
* Windows 7 - 64 bits

For those using any of these platforms please leave a comment on this thread. Please only use a recent autobuild for this. If problems were detected during testing please submit an issue to http://dev.xonotic.org or leave a message on this thread.

Thanks a lot
Reply

#2
I can test on Win 7 64 bit - what release? The current autobuild?
[Image: 249.png] Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out my Newbie Corner!
<ZeRoQL> i think i got 1 proper quad and that cunt halogen fuck me over with a laser
Reply

#3
(08-24-2011, 09:25 AM)Halogene Wrote: I can test on Win 7 64 bit - what release? The current autobuild?

Yes, a recent autobuild or GIT update will do. Thank you!
Reply

#4
Only the autobuild will do. The git repository builds 32bit builds, we still have no 64bit windows build system.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#5
On Windows 7 x64 SDL build sound seems to lag a bit, ie take an item and the take item sound takes about 150 - 200ms to start playing, also sometimes it totally kills all sound on the system and i need to reboot to get it back working (not even uninstalling and re-installing the driver has any effect)
#deathmatchers
Reply

#6
(08-24-2011, 09:11 AM)mand1nga Wrote: * Windows XP -32 bits only

I don't get any major issues with the game and the performance is much better than Nexuiz for exmaple.
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8

Reply

#7
I'm also on XP-32 bits and i can confirm, everything seems to be fine so far.
<Halogene> ok "n1" means "nice one"
<Halogene> "gl" means "good luck"
<Halogene> "fu" means "wow that was wickedly nice that frag"
Screenshot Gallery
Frogg on Instagram
Reply

#8
Doesn't compile (Windows 7 64-bit, Singularity, and Windows CE all report the same error):
dpsoftrast.o: In function `DPSOFTRAST_Interpret_Draw':
C:\Users\BRIANB~1\Desktop\Xonotic\XONOTI~1\xonotic\darkplaces/dpsoftrast.c:5103:
undefined reference to `__builtin_ia32_vec_ext_v4sf'
C:\Users\BRIANB~1\Desktop\Xonotic\XONOTI~1\xonotic\darkplaces/dpsoftrast.c:5104:
undefined reference to `__builtin_ia32_vec_ext_v4sf'
C:\Users\BRIANB~1\Desktop\Xonotic\XONOTI~1\xonotic\darkplaces/dpsoftrast.c:5105:
undefined reference to `__builtin_ia32_vec_ext_v4sf'
collect2: ld returned 1 exit status
make[2]: *** [darkplaces-dedicated.exe] Error 1
make[2]: Leaving directory `/xonotic/darkplaces'
make[1]: *** [bin-debug] Error 2
make[1]: Leaving directory `/xonotic/darkplaces'
make: *** [sv-debug] Error 2
Reply

#9
(08-24-2011, 10:03 AM)divVerent Wrote: Only the autobuild will do. The git repository builds 32bit builds, we still have no 64bit windows build system.

Alright, I've updated the original post. But .. how come the autobuild can compile 64 bits executables but there's not target for them on GIT/SVN?
Reply

#10
mand1nga it has something to do with the latest compiler, ie older versions work Smile
#deathmatchers
Reply

#11
I can confirm that on Windows 7 64bit the sound seemed to constantly lag by almost half a second in the beginning, and I had occasional sound "gaps" like "Blue wi--ins." The constant lagging got better though during gameplay and in the end, after some 10 minutes, I didn't really notice anything akward anymore, except occasional "gaps".

Performance-wise everything was fine.

I used today's autobuild on Win 7 64bit with creative Soundblaster X-FI Titanium.
[Image: 249.png] Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out my Newbie Corner!
<ZeRoQL> i think i got 1 proper quad and that cunt halogen fuck me over with a laser
Reply

#12
I also have autobuild on Windows XP 32bit installed and it works fine, except for two small things: When the game starts the sound seems to lag and repeats for about one second, after that it is all fine. The second issue occurs when a match starts: I shot with a weapon the first time and the fps go down (about 1-5 fps).
These aren´t very annoying problems, I still have another one which is way worse (the ping problem), but it would be nice if they´d be fixed for the next release.
Reply

#13
(08-24-2011, 12:57 PM)mand1nga Wrote:
(08-24-2011, 10:03 AM)divVerent Wrote: Only the autobuild will do. The git repository builds 32bit builds, we still have no 64bit windows build system.

Alright, I've updated the original post. But .. how come the autobuild can compile 64 bits executables but there's not target for them on GIT/SVN?

./all has no mingw64 support yet. Simple... the autobuilds cross compile from Linux.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#14
Windows 7 users: can you try the wgl build instead?
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#15
will do.
[Image: 249.png] Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out my Newbie Corner!
<ZeRoQL> i think i got 1 proper quad and that cunt halogen fuck me over with a laser
Reply

#16
I run the latest autobuild version under Windows Vista 32 bits (yeah, you did read correctly).
No problem at all. Performance are excellent.
Fat.bot.Slim
Reply

#17
xonotic-x64.exe runs perfectly @ windows 7 64bit
MY NOOB STATS:
[Image: 788.png]
Reply

#18
Normal wgl build works without any problem or visible bug, the sound problem is specific to sdl and on the 64 bit binary.
#deathmatchers
Reply

#19
latest git runs fine in OSX lion. should I try an autobuild as well?
Master of mysterious geometries

Imgur Gallery
Reply

#20
(08-25-2011, 03:08 AM)divVerent Wrote:
(08-24-2011, 12:57 PM)mand1nga Wrote:
(08-24-2011, 10:03 AM)divVerent Wrote: Only the autobuild will do. The git repository builds 32bit builds, we still have no 64bit windows build system.

Alright, I've updated the original post. But .. how come the autobuild can compile 64 bits executables but there's not target for them on GIT/SVN?

./all has no mingw64 support yet. Simple... the autobuilds cross compile from Linux.

How do you cross-compile for 64 bit Windows on Linux? What tools are needed? Is there a setup guide somewhere?
Reply

#21
No guide, it's a quite complex setup. Sorry. When I have time, I will try if I can simplify it to only use one compiler Tongue
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#22
btw, about OSX lion, the game runs but only in windowed mode, due to issues with SDL. maybe for now, the default setting can be changed for the OSX build until this issue is corrected?
Master of mysterious geometries

Imgur Gallery
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  Weapon and Lightning Gun Testing Mario 18 9,875 11-11-2014, 08:02 PM
Last Post: Lee_Stricklin
  [SOLVED] NetRadiant compile Windows 7 toneddu2000 21 10,794 09-29-2014, 12:23 PM
Last Post: Mr. Bougo
  q3map2 x64 for Windows Lord Canistra 11 12,725 09-26-2014, 05:52 PM
Last Post: toneddu2000
  any unit testing? soukaina 3 2,553 01-12-2014, 05:24 PM
Last Post: Mr. Bougo
Question Hello and Offering Coding/Testing Help But Having Probs darrell_l 1 1,860 11-07-2013, 01:50 PM
Last Post: Mepper
  The Windows 64-bit executable austen1000 6 5,552 09-17-2013, 05:46 PM
Last Post: austen1000
  I updated the "Compiling in Windows" wiki page Mr. Bougo 2 2,909 08-24-2012, 03:39 PM
Last Post: Mr. Bougo
Video Weapon tutorial video: Electro. HELP NEEDED CuBe0wL 7 5,322 07-14-2011, 05:22 AM
Last Post: CuBe0wL
Bug Coding & Testing HELP needed: Death / intermission chase camera, and damage effects MirceaKitsune 1 3,019 05-01-2011, 09:28 AM
Last Post: MirceaKitsune
  Codendi, the open source platform for Application Lifecycle Management (ALM) PGP_Qz 2 5,689 11-20-2010, 03:48 PM
Last Post: Spaceman

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-