Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SUGGESTION] Alt+tab on Linux

#1
As some of you may be aware, this feature does not work on most id Tech-based games on Linux, including DarkPlaces.

I was wondering that could this feature be fixed in Xonotic, so Linux users could alt+tab their games without any tweaks? Of course alternative way to "alt+tab" is to run Xonotic on different X server, but this requires some knowledge. I remember that a few years ago I used a third-party program to alt+tab id Tech 3-based game Urban Terror on Linux, but I really don't remember the name of that tool... If making alt+tab working on Xonotic requires too much tinkering with the engine code, could that third-party program be included in default Xonotic installation? The only problem is to find the name of that program.

So, who needs this feature?
Reply

#2
I use alt+tab really often in windows. Every time I use Linux, I wonder why it is not working and it bothers me. So I really support this demand Smile
Reply

#3
vid_netwmfullscreen 1, and you have alt+tab in linux too.
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#4
Its a X problem, defaultly no fullscreen application can alt+tab because there is no fullscreen in X, its just window centered and nailed down in such a way it looks like fullscreen, you can try that thing but expect all sorts of ridiculous behaviour.
Reply

#5
If you're using a tiling WM (like DWM or xmonad), try turning vid_fullscreen to 0 and vid_resizable to 1 or 2. Simply set the desired resolution in Nexuiz and let your tiling WM resize the window for you, but remember that the WM will only receive mouse + keyboard events when the console is open.
[Image: vN3NkMA]
(Idea stolen from Mr. Bougo. Hehehehe)
Reply

#6
(09-16-2011, 03:37 AM)C.Brutail Wrote: vid_netwmfullscreen 1, and you have alt+tab in linux too.

Does anyone know why this isn't a default yet?
Reply

#7
Because it can't change the resolution.

If it could (e.g. via XRandR), it'd be default now.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#8
Sorry for resurrecting this thread, but I have this issue and couldn´t manage to make it work with the solutions mentioned above. Using the sdl executable (for glx it´s the same) and vid_netwmfullscreen 1 doesn´t work (using Gnome 2 with Ubuntu 10.10 btw). Any further ideas?
Reply

#9
vid_netwmfullscreen 1 requires a restart. Are you sure it's properly saved?
Reply

#10
Did so. I noticed that it resets the cvar to 0 every time I start the game, so I added the command to my launcher but still it doesn´t work.
Reply

#11
But it is set to 1 now, right?

I'm really not sure what else to say. Can you still alt-tab out when the xonotic console is up?
Reply

#12
It is set to 1, yes.

No, I can´t tab out even if the console is up. Also tried that in game, no difference.
Reply

#13
That's very unusual. What's the value of the vid_grabkeyboard cvar?
Reply

#14
vid_grabkeyboard is set to 0, even with 1 there isn´t any difference.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SUGGESTION] i am going to create a deb package for xonotic linux clerickx 2 65 Yesterday, 04:06 PM
Last Post: Mirio
  [SUGGESTION] Script for setting Linux dedicated server atomic.kidd 4 1,412 10-05-2019, 10:02 AM
Last Post: atomic.kidd
Lightbulb [SUGGESTION] Linux - make dependacies obvious - libcurl thumper 10 7,885 05-07-2012, 09:14 AM
Last Post: hutty

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-