Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Bots get stuck or don't move at all

#1
Hi,

I gotta admit, this is an awesome game, I have been playing Nexuiz before, and just heard of it last month.

Anyway, there are several problems with it. First thing I'd like to deal with, is that bots occasionally get stuck and either try to move when it's not possible or just don't move at all. I have an example of the latter in attached demo:

http://www.mediafire.com/?egc7xw00ef4j097

Of course, this isn't the only map where such stuff happens. I've had it also happen on campgrounds_b4 and aggressor. As for default maps, common choke points for bots seem to be:

1)Stairs next to nex in stormkeep - sometimes bots just get stuck on the stairs
2)Strength in afterslime - sometimes bots don't move for a while, even though there is plenty of room to do so.
Reply

#2
Welcome to Xonotic! Smile

Yeah, it´s well known that the bots aren´t the best ones. Though there are some reasons why bots move in a weird way or don´t move at all:
- The mapper hasn´t added any bot support to the map. (Then bots won´t move or will only grab the next item.)
- Not well optimised botwaypoints, also a thing which a mapper should take care of.
- I think the devs are still working on it to improve the behaviour of bots. (If I´m right... )

rafallus Wrote:stonekeep
Stormkeep Tongue
Reply

#3
Thanks for reply.

As or map name - dumb mistake on my part, corrected.

If so, then I guess it's time to wait and see. There could be a few tweaks to make high difficulty bots more aggressive and bunnyhop more, but that may be already planned to taken care of later as well.
Reply

#4
Better BOT AI is what should be the most important thing to take care of for the developers IMO. Icreasing the graphics isn't needed anymore (IMO again!). What we need now is cool bot AI and interesting singleplayer (both have a lot in common to be honest). Anyway:
Welcome to Xonotic, Rafallus! Where are you from? What's your background in gaming (exepting nexuiz ofc)? There was a thread called "What's your national language" or sth like that I am not sure about that.Confused You can share with us some informations about yourself and we will happily hack your computer for you! Smile
Reply

#5
Hello, Justin!

Admittedly, this is probably the nicest welcome message I have ever seen on any board I've been on.

I'm from Poland and played quite a few FPS's like that (Q3 and UT series mainly, a bit of older Q2 and other open source game: Digital Paint: Paintball 2). I've checked out that language thread and made a post as well.
Reply

#6
(01-17-2012, 04:48 PM)rafallus Wrote: Admittedly, this is probably the nicest welcome message I have ever seen on any board I've been on.

Welcome to this community actually! Wink

http://forums.xonotic.org/forumdisplay.php?fid=28
Reply

#7
Oddly enough, some maps have autogenerated waypoints, yet bots still don't move. That's a curious issue to me.

Attached file contains waypoint files for several maps. They should be in xonotic/data/data/maps folder. Those who already have those maps, should have same files anyway, but if not, I can provide those maps as well.
Reply

#8
The autogenerated files (filename.waypoints.cache) do not make it work. You (or any other person, preferably a mapper) have to manually create a bot waypoint file (filename.waypoints). That can only be done ingame using some console commands.
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
Thumbs Up [NEED HELP] How to add more bots in multiplayer funbags 0 641 03-30-2023, 10:13 PM
Last Post: funbags
  [SOLVED] FPS Stuck at 60? Eile 3 2,861 07-27-2022, 04:11 PM
Last Post: FAF
  [SOLVED] Mapping: Move permeable wall upon trigger stingray300k 5 2,062 05-26-2021, 10:19 AM
Last Post: stingray300k
  [SOLVED] Textures don't load at other side of warpzone bananovenc 6 3,251 06-11-2020, 12:56 PM
Last Post: bananovenc
  [SOLVED] No stats for the player Ubuntu 19.04 - just don't use the flathub version Fiorentino 2 3,201 04-20-2020, 07:42 AM
Last Post: Fiorentino
  [NEED HELP] Sudden loss of sound in Xonotic, can not get it to return. SeveredinTwain 5 4,345 03-26-2020, 05:55 AM
Last Post: FAF
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 4,118 01-03-2020, 11:31 AM
Last Post: SpiKe
  [NEED HELP] Add Bots using Console in Xonotic OpenSourceGames 1 8,607 08-09-2019, 10:16 AM
Last Post: martin-t
Photo [NEED HELP] How do I get this crosshair (photo) sovietcat 2 2,809 02-23-2019, 03:21 AM
Last Post: sovietcat
Photo [NEED HELP] How do you get this crosshair? sovietcat 0 2,148 02-22-2019, 12:50 PM
Last Post: sovietcat

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-