Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] [solved]netradian crash when compilling a map

#1
Hello, here the line I have when netradian crash at the verry begining of any map compilling:

kernel: [ 5422.288394] radiant.x86[4961]: segfault at 10 ip 081e7386 sp bfd78570 error 4 in radiant.x86[8048000+1ee000]

Here the kernel I use: 3.1.4-1-ARCH #1 SMP PREEMPT

Nothing appear in the netradian log file. The problem is new since end of november when I have tried to compile a map, well maybe from october when I switch the OS to ARCH but I did not test netradian at that time.
I updated 3 or 4 times the xonotic git version and compile netradian successfully.

I guess the problem is on my side but I though important to notice it in case of a xonotic bug.

I'd like to have some hints or advices from you guys to help me to debug that.

I have two days to work on the maps befor to plublish the sources then its going to be continue at the end of january.
Peace.
===========================================
-----------------------------------------------------------------------------------------------
After updating the OS I use, updating the git xonotic and the autobuild version the compiling keep crashing. So I almost use the Hutty's solution which was to change my linux flavor. I use archlinux and I though to change it for unbuntu, I did not liked the idea but I gave myself a last chance and

IT WORKS!!!

I just install the wine program to run the windows versions of netradian which is on the autobuild version of xonotic. The maps can be compiled now.
Ok it is a bit anoying but I can have the job done untill I find right thing to do.
Reply

#2
For me it seems like your system isn´t set up right:
Leeloo Wrote:kernel: [ 5422.288394] radiant.x86[4961]: segfault at 10 ip 081e7386 sp bfd78570 error 4 in radiant.x86[8048000+1ee000]
Leeloo Wrote:The problem is new since end of november when I have tried to compile a map, well maybe from october when I switch the OS to ARCH

Maybe you update your system? Helped me a lot when I was using Gentoo. Wink
Reply

#3
I'm just got things set up again (after switching from kubuntu to opensuse).. and I have the same problem.0 I hit the render button for a simple test map . and boom . netradiant crashes, and konsole spits out a segmentation fault.

I dont think there is anything strange with my system.. as far as I know...

--edit--

this happens in both the net radiant git, and the version from the "Latest Mapping Support" thingy


--nother edit--

It also crashes with a version of netradiant from last summner (June-ish -- grabbed from git)
possibilities

--netradiant has been broken for a very long time
--something is very wrong with my system
--something is very wrong with "make"
--netradiant just hates me

here is random system information that might --- but probably wont be very helpful

--os

OS: Linux 3.1.0-1.2-desktop x86_64
Current user: hutty@linux-dzi4.site
System: openSUSE 12.1 (x86_64)
KDE: 4.7.2 (4.7.2) "release 5"

--graphics
Vendor: ATI Technologies Inc
Model: Mobility Radeon HD 4500 Series
2D driver: fglrx

--cpu

Processor (CPU): Intel® Core™ i5 CPU M 520 @ 2.40GHz
Speed: 1,199.00 MHz
Cores: 4

mems-

Total memory (RAM): 3.7 GiB
Free memory: 1.6 GiB (+ 1.0 GiB Caches)
Free swap: 3.9 GiB

--make version (probably not this -- i can compile other things)

GNU Make 3.82
Built for x86_64-unknown-linux-gnu



ANOTHER Edit--------

q3map2 can compile my maps IF launched from command-line. So there must be some error occurring between netradiant and q3map2
Reply

#4
After much mulling about I finailly went back to kubuntu ... and everything works like a charm

solution (for me) dont use SUSE
Reply

#5
Hehe there's probably another solution, sorry you didn't get there :<
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Question [NEED HELP] Certain maps crash my game :( flexo 4 1,365 12-07-2020, 09:25 AM
Last Post: Ecthelion
  [NEED HELP] Need old rifle model(solved) Kotangens 8 596 08-27-2020, 01:42 AM
Last Post: Kotangens
Question [NEED HELP] How to create warpzones? (solved) Kotangens 10 1,101 08-19-2020, 07:05 AM
Last Post: Kotangens
Question [NEED HELP] How to use textures for radiant(win version)? (solved) Kotangens 4 861 08-12-2020, 01:33 AM
Last Post: Kotangens
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 8 1,209 12-25-2019, 10:07 PM
Last Post: Lyberta
  [NEEDS INFO] Game Crash On Load Castor 0 1,188 05-31-2018, 09:06 AM
Last Post: Castor
  [SOLVED] NetRadiant crash "Got to split the buffer" PinkRobot 7 3,223 08-27-2016, 06:16 AM
Last Post: PinkRobot
  [SOLVED] [Solved]How to install or runn Xonotic Kaddafi 10 6,409 10-10-2015, 12:09 PM
Last Post: Halogene
  [SOLVED] Crash Upon Starting Second Level After Quitting First ehrenbrav 2 2,464 06-10-2015, 09:41 AM
Last Post: ehrenbrav
  [BUG] INFO_ITEM_WEAPON_UNAVAILABLE Crash coppelius 3 3,236 01-02-2015, 06:21 PM
Last Post: Mario

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-